Bug 251387 - Command: `dscl . -list /Users` does not reveal users that begin with a period (or perhaps other special characters)
Summary: Command: `dscl . -list /Users` does not reveal users that begin with a period...
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: standards (show other bugs)
Version: Unspecified
Hardware: amd64 Any
: --- Affects Many People
Assignee: Mateusz Piotrowski
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-25 23:17 UTC by Dana Morrison
Modified: 2020-11-26 09:59 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dana Morrison 2020-11-25 23:17:30 UTC
Apple is passing off this issue as "not an issue" as it seems to be affected by the underlying system.  I do not know where else to go, but to report the problem here.

This issue was discovered in macOS where creating users with a period is permitted by the GUI (Users/Preferences as well as during the initial setup).  Additionally, subsequent users created after the user that was created using with a period as a prefix to the username do not get a proper UID.

Attempts to reveal the hidden account do not work using `dscl . -list /Users`  Additionally, attempts to find the account if the home directory is moved becomes very challenging.  If macOS is build on the FreeBSD structure, the hidden account might be noticed by looking at the /var/db/dslocal/nodes/Default/Users directory (or FreeBSD equivalent).

No known patch/fix is available.
Comment 1 Mateusz Piotrowski freebsd_committer 2020-11-26 09:59:15 UTC
Hello Dana,

dscl is not a part of the FreeBSD base system. This seems to be macOS-specific utility so unfortunately we cannot really do anything about it.