Bug 251410 - pkg-depends error
Summary: pkg-depends error
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Fernando Apesteguía
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-26 18:48 UTC by albert.shih
Modified: 2020-11-27 08:45 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description albert.shih 2020-11-26 18:48:54 UTC
Hi, 

I've got some strange error with poudriere to build port. 

I known it's for a non supported version of FreeBSD, but anyway...

Under FreeBSD 11.2 I've got for *every* ports build by poudriere this error at the end of every build log file

--End resource limits--
=======================<phase: check-sanity   >============================
/!\ WARNING /!\

Ports Collection support for your FreeBSD version has ended, and no ports are
guaranteed to build on this system. Please upgrade to a supported release.

===>  License MIT accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
set: Illegal option -o pipefail
*** Error code 2

Stop.

Regards
Comment 1 albert.shih 2020-11-26 18:51:17 UTC
Forget to say I've got exact same problem with 12.0
Comment 2 Fernando Apesteguía freebsd_committer 2020-11-27 07:41:20 UTC
(In reply to albert.shih from comment #1)

You are probably referring to this:

https://lists.freebsd.org/pipermail/svn-ports-all/2020-November/272893.html
Comment 3 Fernando Apesteguía freebsd_committer 2020-11-27 08:45:21 UTC
Current supported releases are: 12.2, 12.1, 11.4.

Sorry about that. It would be wise to update to a supported release.

Closing.