Bug 251419 - mail/evolution(-ews) & databases/evolution-data-server: Update to 3.38.2
Summary: mail/evolution(-ews) & databases/evolution-data-server: Update to 3.38.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
: 251299 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-27 02:35 UTC by Neel Chauhan
Modified: 2020-12-08 10:25 UTC (History)
1 user (show)

See Also:
tcberner: maintainer-feedback+


Attachments
Patch (Revision 1) (17.64 KB, patch)
2020-11-27 02:35 UTC, Neel Chauhan
no flags Details | Diff
Patch (Revision 2) (17.16 KB, patch)
2020-12-04 19:19 UTC, Neel Chauhan
no flags Details | Diff
Patch (Revision 3) (16.41 KB, patch)
2020-12-04 19:21 UTC, Neel Chauhan
no flags Details | Diff
Patch (Revision 4) (16.00 KB, patch)
2020-12-04 19:23 UTC, Neel Chauhan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Neel Chauhan freebsd_committer 2020-11-27 02:35:12 UTC
Created attachment 220020 [details]
Patch (Revision 1)

Passes poudriere.
Comment 1 Neel Chauhan freebsd_committer 2020-12-02 05:56:46 UTC
*** Bug 251299 has been marked as a duplicate of this bug. ***
Comment 2 Tobias C. Berner freebsd_committer 2020-12-04 19:11:07 UTC
Moin moin

Thanks for the patch, but please make sure you check your plist changes


That looks wrong to me:
  58   │ -%%SPAMASSASSIN%%lib/evolution/modules/module-spamassass
  61   │ -%%YTNEF%%lib/evolution/modules/module-tnef-attachment.s
  69   │ -%%PST%%lib/evolution/plugins/liborg-gnome-pst-import.so
  77   │ -%%PST%%lib/evolution/plugins/org-gnome-pst-import.eplug


mfg Tobias
Comment 3 Neel Chauhan freebsd_committer 2020-12-04 19:19:38 UTC
Created attachment 220257 [details]
Patch (Revision 2)

I re-added these entries.
Comment 4 Neel Chauhan freebsd_committer 2020-12-04 19:21:48 UTC
Created attachment 220258 [details]
Patch (Revision 3)

Don't re-order a plist variable.
Comment 5 Neel Chauhan freebsd_committer 2020-12-04 19:23:38 UTC
Created attachment 220259 [details]
Patch (Revision 4)

Found a few issues with the plist so fixed it.
Comment 6 commit-hook freebsd_committer 2020-12-08 10:25:26 UTC
A commit references this bug:

Author: tcberner
Date: Tue Dec  8 10:25:23 UTC 2020
New revision: 557276
URL: https://svnweb.freebsd.org/changeset/ports/557276

Log:
  mail/evolution(-ews) & databases/evolution-data-server: Update to 3.38.2

  PR:		251419
  Submitted by:	Neel Chauhan <neel@neelc.org>

Changes:
  head/databases/evolution-data-server/Makefile
  head/databases/evolution-data-server/distinfo
  head/mail/evolution/Makefile
  head/mail/evolution/distinfo
  head/mail/evolution/pkg-plist
  head/mail/evolution-ews/Makefile
  head/mail/evolution-ews/distinfo
Comment 7 Tobias C. Berner freebsd_committer 2020-12-08 10:25:40 UTC
Committed. Thanks.