Bug 251471 - sysutils/slurm-wlm: does not find lua 5.4
Summary: sysutils/slurm-wlm: does not find lua 5.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jason W. Bacon
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2020-11-29 22:29 UTC by Greg V
Modified: 2020-12-09 13:45 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (jwb)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg V 2020-11-29 22:29:27 UTC
With default lua set to 5.4, the build fails to find lua:

checking for lua... no
configure: WARNING: unable to locate lua package

As a result, can't package:

===>  Building package for slurm-wlm-20.02.1_2
pkg-static: Unable to access file /wrkdirs/usr/ports/sysutils/slurm-wlm/work/stage/usr/local/lib/slurm/cli_filter_lua.a:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/sysutils/slurm-wlm/work/stage/usr/local/lib/slurm/cli_filter_lua.so:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/sysutils/slurm-wlm/work/stage/usr/local/lib/slurm/job_submit_lua.a:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/sysutils/slurm-wlm/work/stage/usr/local/lib/slurm/job_submit_lua.so:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/sysutils/slurm-wlm/work/stage/usr/local/lib/slurm/jobcomp_lua.a:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/sysutils/slurm-wlm/work/stage/usr/local/lib/slurm/jobcomp_lua.so:No such file or directory
Comment 1 Jason W. Bacon freebsd_committer 2020-11-30 16:02:53 UTC
Thanks for the report.

Please let me know if this hack fixes the issue for you:

https://github.com/outpaddling/freebsd-ports-wip/tree/master/slurm-wlm
Comment 2 Jason W. Bacon freebsd_committer 2020-11-30 18:02:25 UTC
FYI...

https://bugs.schedmd.com/show_bug.cgi?id=10308
Comment 3 Greg V 2020-12-01 18:55:57 UTC
(In reply to Jason W. Bacon from comment #1)
Yes, works fine!
Comment 4 commit-hook freebsd_committer 2020-12-01 22:03:19 UTC
A commit references this bug:

Author: jwb
Date: Tue Dec  1 22:02:48 UTC 2020
New revision: 556796
URL: https://svnweb.freebsd.org/changeset/ports/556796

Log:
  sysutils/slurm-wlm: Patch in lua 5.4 support

  PR opened upstream
  Make sure patch files have meaningful names

  PR:             251471
  Reported by:    greg@unrelenting.technology

Changes:
  head/sysutils/slurm-wlm/Makefile
  head/sysutils/slurm-wlm/files/patch-c8be6ceb.c
  head/sysutils/slurm-wlm/files/patch-configure
  head/sysutils/slurm-wlm/files/patch-src_scancel_scancel.c
  head/sysutils/slurm-wlm/files/patch-src_scancel_scancel.h
Comment 5 Jason W. Bacon freebsd_committer 2020-12-01 22:04:08 UTC
Thanks for the heads-up!
Comment 6 commit-hook freebsd_committer 2020-12-09 13:45:04 UTC
A commit references this bug:

Author: jwb
Date: Wed Dec  9 13:45:00 UTC 2020
New revision: 557373
URL: https://svnweb.freebsd.org/changeset/ports/557373

Log:
  MFH: r556796 r557295

  sysutils/slurm-wlm: Patch in lua 5.4 support

  PR opened upstream
  Make sure patch files have meaningful names

  PR:             251471
  Reported by:    greg@unrelenting.technology

  sysutils/slurm-wlm: Back out -fno-common patches, add -fcommon flag

  Fixes runtime regression caused by r546150

  Reported by:    jrm

  Approved by:	blanket bug fix

Changes:
_U  branches/2020Q4/
  branches/2020Q4/sysutils/slurm-wlm/Makefile
  branches/2020Q4/sysutils/slurm-wlm/files/patch-c8be6ceb.c
  branches/2020Q4/sysutils/slurm-wlm/files/patch-configure
  branches/2020Q4/sysutils/slurm-wlm/files/patch-src_plugins_select_cons__tres_job__test.c