Bug 251505 - databases/ruby-bdb can not install because of a bad path for it's documentation
Summary: databases/ruby-bdb can not install because of a bad path for it's documentation
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-ruby (Nobody)
URL:
Keywords:
: 251681 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-12-01 13:00 UTC by Daniel Toschläger
Modified: 2020-12-08 12:39 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (ruby)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Toschläger 2020-12-01 13:00:35 UTC
Hi
I ran into an aborted installation of databases/ruby-bdb.

[snip]
(cd /usr/ports/databases/ruby-bdb/work/bdb-0.6.6/docs/doc && /bin/sh -c '(/usr/bin/find -Ed $1 $3 | /usr/bin/cpio -dumpl $2 >/dev/null 2>&1) &&  /usr/bin/find -Ed $1 $3 \(   -type d -exec /bin/sh -c '\''cd '\''$2'\'' && chmod 755 "$@"'\'' . {} +  -o -type f -exec /bin/sh -c '\''cd '\''$2'\'' && chmod 0644 "$@"'\'' . {} + \)' COPYTREE_SHARE . /usr/ports/databases/ruby-bdb/work/stage/usr/local/share/doc/ruby27/bdb/doc)
cd: /usr/ports/databases/ruby-bdb/work/bdb-0.6.6/docs/doc: No such file or directory
*** Error code 2

Stop.
make[1]: stopped in /usr/ports/databases/ruby-bdb
*** Error code 1

Stop.
make: stopped in /usr/ports/databases/ruby-bdb
[snap]

My lousy workaround was to create the doc dir in docs and cp anything from docs into doc.

Then the installation worked. This path must be changed.

Kind regards
Daniel
Comment 1 Hajimu UMEMOTO freebsd_committer 2020-12-02 14:05:16 UTC
I cannot reproduce your problem, here.
The docs/doc directory should be created during build process.
I suspect your installation of rdoc is broken.
Please re-install rubygem-rdoc, then retry it.
Comment 2 Daniel Toschläger 2020-12-02 15:13:57 UTC
I was making a portupgrade -a, updating ruby from 2.6 to 2.7. This came as a dependency. I today de- and re- installed ruby-gems and ruby-bdb (also from ports) and all went well, thank you.

Solved, just a version mismatch. Sorry for the time.

Kind regards
Daniel
Comment 3 Hajimu UMEMOTO freebsd_committer 2020-12-08 12:39:32 UTC
*** Bug 251681 has been marked as a duplicate of this bug. ***