Bug 251590 - textproc/ripgrep: fails to build with CPUTYPE=haswell (avx)
Summary: textproc/ripgrep: fails to build with CPUTYPE=haswell (avx)
Status: Closed DUPLICATE of bug 251425
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-04 23:55 UTC by Greg V
Modified: 2020-12-06 14:58 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (petteri.valkonen)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg V 2020-12-04 23:55:12 UTC
With CPUTYPE=haswell and SIMD=on, the build fails:

error[E0432]: unresolved import `crate::arch::x86_64::_mm_shuffle_pi8`
   --> /wrkdirs/usr/ports/textproc/ripgrep/work/ripgrep-12.1.1/cargo-crates/packed_simd-0.3.3/src/codegen/shuffle1_dyn.rs:40:29
    |
40  |                         use crate::arch::x86_64::_mm_shuffle_pi8;
    |                             ^^^^^^^^^^^^^^^^^^^^^---------------
    |                             |                    |
    |                             |                    help: a similar name exists in the module: `_mm_shuffle_epi8`
    |                             no `_mm_shuffle_pi8` in `arch::x86_64`
...
297 | impl_shuffle1_dyn!(u8x8);
    | ------------------------- in this macro invocation
    |
    = note: this error originates in a macro (in Nightly builds, run with -Z macro-backtrace for more info)

A workaround is to do

_CPUCFLAGS:=

in the port.. (maybe we need some less hacky way to do the same thing in the framework, like a CPUTYPE_UNSAFE=yes or something)
Comment 1 Mikael Urankar freebsd_committer 2020-12-06 14:58:57 UTC

*** This bug has been marked as a duplicate of bug 251425 ***