Bug 251635 - astro/googleearth: cannot start, tries to load wrong url
Summary: astro/googleearth: cannot start, tries to load wrong url
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Fernando Apesteguía
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-06 11:27 UTC by tech-lists
Modified: 2021-10-19 12:55 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tech-lists 2020-12-06 11:27:19 UTC
Hi,

astro/googleearth tries and fails to load at startup http://kh.google.com:80 and this failure is because that url 404s. There appears nowhere to change this within the program.

context:

ports: 557130 system: 12-stable 368361
Comment 1 Fernando Apesteguía freebsd_committer 2020-12-09 12:16:29 UTC
(In reply to tech-lists from comment #0)

Any changes on your side?

https://support.google.com/earth/thread/38971495?hl=en
Comment 2 tech-lists 2020-12-09 17:03:45 UTC
(In reply to Fernando Apesteguía from comment #1)

No.

The port is open and the IP resolves:

[...]

% nmap -p 80 kh.google.com
Starting Nmap 7.91 ( https://nmap.org ) at 2020-12-09 16:53 GMT
Nmap scan report for kh.google.com (216.58.210.46)
Host is up (0.011s latency).
Other addresses for kh.google.com (not scanned): 2a00:1450:4009:810::200e
rDNS record for 216.58.210.46: lhr25s11-in-f46.1e100.net

PORT   STATE SERVICE
80/tcp open  http

Nmap done: 1 IP address (1 host up) scanned in 0.30 seconds
[...]

Viewed in lynx, this is the error:

[...]

   404. [INS: That’s an error. :INS]

   The requested URL / was not found on this server. [INS: That’s all we know. :INS]

   [Document has only hidden links. Use the 'l'ist command.]

[...]
hidden links show www.google.com

The problem appears to be on the google side if it's meant to load "/" or in the program, I guess, if there's supposed to be a string after the slash
Comment 3 tech-lists 2020-12-09 17:31:23 UTC
also 7.1.7 is ancient, there's linux versions for 7.3.3 so am not sure if this version is even fixable
Comment 4 tech-lists 2020-12-09 22:44:06 UTC
version in ports is 7.1.7.2606_1,3
Comment 5 tech-lists 2021-05-20 04:08:35 UTC
misspelled portname
Comment 6 Peter Dean 2021-10-05 05:12:14 UTC
Problem is version - 7.1.8 or later required
https://support.google.com/earth/thread/43329999/ending-support-for-earlier-versions-of-google-earth?hl=en
Comment 7 commit-hook freebsd_committer 2021-10-19 12:52:38 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=0fdd00b27df5ca783f0e6d87618af662c9082e9e

commit 0fdd00b27df5ca783f0e6d87618af662c9082e9e
Author:     Fernando Apesteguía <fernape@FreeBSD.org>
AuthorDate: 2021-10-19 12:28:10 +0000
Commit:     Fernando Apesteguía <fernape@FreeBSD.org>
CommitDate: 2021-10-19 12:46:28 +0000

    astro/google-earth: mark as DEPRECATED

    Google Earth needs version 7.1.8 or later required to run[1] since October 2020.

    In order to update the port we need _at least_ linux ports for:

     * libproxy
     * gstreamer
     * gstreamer-plugin-base
     * libmodman
     * orc

    But in the end it fails at runtime because our linuxolator glibc is too old
    (GLIBC_2.17 vs GLIBC_2.18).

    [1] https://support.google.com/earth/thread/43329999/ending-support-for-earlier-versions-of-google-earth?hl=en

    PR: 251635

 astro/google-earth/Makefile | 3 +++
 1 file changed, 3 insertions(+)