Bug 251660 - games/linux-enemyterritory: No more sound
Summary: games/linux-enemyterritory: No more sound
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Barbara Guida
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-07 06:36 UTC by Pol Dellaiera
Modified: 2021-06-17 09:56 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pol Dellaiera 2020-12-07 06:36:17 UTC
Hello,

I just registered to report this issue.

I upgraded my laptop and my workstation on 12.2-RELEASE and since then, I cannot have anymore sound in Enemy Territory.

It has been working flawlessly on previous versions of FreeBSD.
Comment 1 Edward Tomasz Napierala freebsd_committer 2021-05-26 11:22:05 UTC
Does sound work for you in native FreeBSD apps?
Comment 2 Pol Dellaiera 2021-05-26 11:39:40 UTC
Hello,

Yes sounds works perfectly.

I will upgrade to 13 very soon and provide some feedback here as well asap.
Comment 3 Barbara Guida freebsd_committer 2021-06-02 08:04:34 UTC
I *think* that the problem is due to the fact that et uses OSS for audio and that it's not supported anymore since compat.linux.osrelease: 3.2.0 / linux_base-c7 (linux-c7-alsa-lib?).
Comment 4 Barbara Guida freebsd_committer 2021-06-17 02:34:41 UTC
(In reply to Pol Dellaiera from comment #0)
Were you running already running linux_base-c7 before upgrading to 12.2-RELEASE?
I want to understand if the problem is related to 12.2-RELEASE or to the move from linux_base-c6 to linux_base-c7.
Comment 5 Barbara Guida freebsd_committer 2021-06-17 02:41:29 UTC
(In reply to Pol Dellaiera from comment #0)
And trying to understand which was the last version where the sound was working, which FreeBSD version were you running before upgrading to 12.2-RELEASE?
Comment 6 Pol Dellaiera 2021-06-17 09:56:21 UTC
Hello,

I won't be able to tell which version of BSD I was using. I think it was 12.0-RELEASE.

Regarding linux_base-c6 or c7, I have absolutely no clue.

I will continue to search a bit and let you know.

This is a real pity that it's no more working :(