Bug 251677 - finance/quickfix drop python2 support
Summary: finance/quickfix drop python2 support
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rene Ladan
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-08 00:17 UTC by m.tsatsenko
Modified: 2021-01-12 20:51 UTC (History)
2 users (show)

See Also:


Attachments
patch (3.12 KB, text/plain)
2020-12-08 00:17 UTC, m.tsatsenko
m.tsatsenko: maintainer-approval+
Details
updated patch (2.83 KB, patch)
2021-01-03 21:58 UTC, m.tsatsenko
m.tsatsenko: maintainer-approval+
Details | Diff
fixed (hopefully) patch (2.74 KB, patch)
2021-01-11 22:51 UTC, m.tsatsenko
m.tsatsenko: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description m.tsatsenko 2020-12-08 00:17:55 UTC
Created attachment 220362 [details]
patch

- Switch python version from 2.7 to 3.7

QA:
poudriere 122amd64 - OK
portlint - no errors
Comment 1 Rene Ladan freebsd_committer 2021-01-01 14:31:44 UTC
It fails to build here on 12.2-amd64 with PYTHON off, see https://people.freebsd.org/~rene/stuff/quickfix-1.15.1.log
Comment 2 Rene Ladan freebsd_committer 2021-01-01 14:33:35 UTC
(In reply to Rene Ladan from comment #1)
Ah, I think this is because the CONFIGURE_ARGS line to disable Python gets removed in this patch.
Comment 3 Rene Ladan freebsd_committer 2021-01-01 14:41:33 UTC
(In reply to Rene Ladan from comment #2)
Nope (and that line was indeed wrong), but adding "python" to PYTHON_CONFIGURE_WITH does not help either.
Comment 4 m.tsatsenko 2021-01-03 21:58:11 UTC
Created attachment 221256 [details]
updated patch

Bring back accidentally removed CONFIGURE_ARGS line
Comment 5 Rene Ladan freebsd_committer 2021-01-04 18:32:13 UTC
(In reply to m.tsatsenko from comment #4)
That line was wrong to begin with, see example 5.40 of https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/makefile-options.html for background. 

The --without-python option is unknown to configure and --without-python3 is correctly handled by the PYTHON_CONFIGURE_WITH helper. The problem is that somehow configure outputs the wrong Makefile.
Comment 6 m.tsatsenko 2021-01-10 13:23:21 UTC
Right. It should be --without-python2.

Regarding --without-python3. PYTHON_CONFIGURE_WITH somehow doenst work properly in poudrierre. Works fine in a live system though. It is passed to the configure, but for some reason doesnt seem to have any effect. I guess that was the reason why I added --without-python3 in the first place.
Comment 7 m.tsatsenko 2021-01-10 13:36:36 UTC
And honestly I don't see any real point in wasting more time trying to make it build. It does not work anyway: any python script I tried to run segfaults at start.

Therefore I suggest to remove python support altogether.
Comment 8 Rene Ladan freebsd_committer 2021-01-11 19:50:14 UTC
(In reply to m.tsatsenko from comment #7)
Yeah, I was perhaps getting a bit academical. But if it doesn't work anyway it is probably indeed better to just remove it.
Comment 9 m.tsatsenko 2021-01-11 21:47:18 UTC
I think I figured it out and managed to make it build successfully with both PYHON enabled and disabled. Will update the patch shortly
Comment 10 m.tsatsenko 2021-01-11 22:51:20 UTC
Created attachment 221479 [details]
fixed (hopefully) patch

This version builds fine with both PYTHON enabled and disabled (poudrierre 122amd64)
Comment 11 Rene Ladan freebsd_committer 2021-01-12 20:51:00 UTC
Your latest patch indeed builds fine, I committed it.
Comment 12 commit-hook freebsd_committer 2021-01-12 20:51:21 UTC
A commit references this bug:

Author: rene
Date: Tue Jan 12 20:50:24 UTC 2021
New revision: 561379
URL: https://svnweb.freebsd.org/changeset/ports/561379

Log:
  finance/quickfix: migrate to Python 3

  PR:		251677 [1]
  PR:		249685 [2]
  Submitted by:	maintainer [1]
  Submitted by:	swills [1]

Changes:
  head/finance/quickfix/Makefile
  head/finance/quickfix/files/patch-m4_ax__python.m4