Bug 251732 - net/routinator: Update to 0.8.2
Summary: net/routinator: Update to 0.8.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jason E. Hale
URL: https://www.nlnetlabs.nl/news/2020/De...
Keywords:
: 251144 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-12-10 14:35 UTC by Jaap Akkerhuis
Modified: 2021-01-22 12:29 UTC (History)
3 users (show)

See Also:


Attachments
patch tp update (49.46 KB, patch)
2020-12-10 14:35 UTC, Jaap Akkerhuis
jaap: maintainer-approval+
Details | Diff
patch to upgrade against slightly newer Makefile (49.48 KB, patch)
2020-12-10 15:11 UTC, Jaap Akkerhuis
jaap: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jaap Akkerhuis 2020-12-10 14:35:20 UTC
Created attachment 220425 [details]
patch tp update

This update also contains improvements as suggested by PR #251144


Release notes for 0.8.2 ‘Once More, with Feeling’

All users of Routinator 0.8.0 and 0.8.1 are encouraged to upgrade
to this release.

Changes

* As the rules proposed by draft-ietf-sidrops-6486bis turned
  out to be too strict, validation has been relaxed again. A CA is
  now only rejected and all its objects ignored if the manifest or
  CRL are invalid or if any of the objects listed on the manifest
  are either missing or have a different hash. Previously, a CA was
  rejected entirely if objects themselves where invalid for any
  reason, including cases such as expired child certificates. (#438)

Bug Fixes

* Switch logging to the configured target for the update command. (#433)

Other Changes

* Update minor dependencies in Cargo.lock. (#439)

Release notes for 0.8.1 ‘Pure as New York Snow’

Bug Fixes

* VRPs filtered via local exceptions are dropped again. In 0.8.0,
  they were only added to the metrics but not actually dropped.
  (#424, discovered by @cwiech)

* The prefix validation option incorrectly matched VRPs for host
  prefixes to prefixes with an identical bit pattern of any length.
  (Found by [@vamseedhar-reddyvari] and fixed in #415 by @morrowc
  and @aaronw112358)

* The config file option for the policy on dealing with objects on
  unknown types is now correctly spelled unknown-objects (with a
  dash rather than an underscore). The old spelling will be also
  be accepted in 0.8 releases. (Found and fixed by @johannesmoos,
  #413, #416.)

* The config file option rtr-tcp-keepalive now accepts an integer
  value as it should have from the beginning (and the config command
  even created). For the time being, both integers and strings will
  be accepted. String values will be rejected starting with 0.9.0.
  ([#427], discovered by @johannesmoos)

New

* The log output of the HTTP /log endpoint now states the start
  date of the validation run it represents. (#426)
Comment 1 Fernando Apesteguía freebsd_committer 2020-12-10 14:56:58 UTC
^Triage: Simplifying title

Q/A: patch did not apply cleanly. Would you mind checking it?

The patch seems to have been generated against a version of the Makefile which did not have PORTREVISION.

Thanks!
Comment 2 Jaap Akkerhuis 2020-12-10 15:11:53 UTC
Created attachment 220426 [details]
patch to upgrade against slightly newer Makefile

Fidn;t realize there was a revised Makefile. Fixed
Comment 3 Fernando Apesteguía freebsd_committer 2020-12-10 15:28:56 UTC
(In reply to Jaap Akkerhuis from comment #2)

Excellent, thanks!

PORTREVISION was added after the upgrade of lang/rust to 1.48.0

------------------------------------------------------------------------
r556157 | mikael | 2020-11-24 13:48:53 +0100 (Tue, 24 Nov 2020) | 8 lines

lang/rust: Update to 1.48.0

Changes: https://github.com/rust-lang/rust/releases/tag/1.48.0

Reviewed by:    jbeich
Tested by:      bdragon, jbeich, mikael
Differential Revision:  https://reviews.freebsd.org/D27293
Comment 4 Jason E. Hale freebsd_committer 2021-01-22 12:25:18 UTC
*** Bug 251144 has been marked as a duplicate of this bug. ***
Comment 5 commit-hook freebsd_committer 2021-01-22 12:28:15 UTC
A commit references this bug:

Author: jhale
Date: Fri Jan 22 12:28:06 UTC 2021
New revision: 562299
URL: https://svnweb.freebsd.org/changeset/ports/562299

Log:
  net/routinator: Update to 0.8.2 [1]

  Fix repository initialization. [2]

  PR:		251732 [1], 251144 [2]
  Submitted by:	Jaap Akkerhuis <jaap@NLnetLabs.nl> (maintainer) [1]
  Reported by:	C <cm@appliedprivacy.net> [2]

Changes:
  head/net/routinator/Makefile
  head/net/routinator/distinfo
  head/net/routinator/files/patch-etc_routinator.conf.example
  head/net/routinator/files/pkg-message.in
  head/net/routinator/files/routinator.in
  head/net/routinator/pkg-plist
Comment 6 Jason E. Hale freebsd_committer 2021-01-22 12:29:41 UTC
Committed, thanks! (I fixed a few minor typos.)