Bug 251950 - devel/lemon: update to latest commit
Summary: devel/lemon: update to latest commit
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jason E. Hale
URL: https://www.sqlite.org/src/finfo?name...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-19 01:45 UTC by Yakov Galka
Modified: 2021-01-22 11:13 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (vmagerya)


Attachments
lemon-3.34 (910 bytes, patch)
2020-12-21 20:01 UTC, Vitaly Magerya
vmagerya: maintainer-approval+
Details | Diff
lemon-3.34.diff.txt (1.15 KB, patch)
2020-12-23 08:16 UTC, Vitaly Magerya
vmagerya: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yakov Galka 2020-12-19 01:45:09 UTC
Current version "1.69" seems to be from circa 2014. SQLite version had since seen a lot of changes (https://www.sqlite.org/src/finfo?name=tool/lemon.c&m&ci=tip), in particular %token and %extra_context were introduced.

SQLite doesn't release an official tar for this, so it would be great if the maintainer updates the tar on their current host.
Comment 1 Vitaly Magerya 2020-12-21 20:01:25 UTC
Created attachment 220790 [details]
lemon-3.34

Yeah, an update is long overdue. I've put lemon.c and lempar.c
from SQLite 3.34 release into [1].

Note that [1] is only available over ipv6 at the moment,
so some sort of a mirror would be really useful (previously
amdmi3@ provided such a mirror on his site; big thanks to
him).

I'm also attaching a port update. Would be great if someone
would test it before comitting.

[1] http://tx97.net/pub/distfiles/lemon-3.34.tar.bz2
Comment 2 Chris Hutchinson 2020-12-21 20:40:12 UTC
You can use me as an ipv4 mirror:

https://BSDforge.com/projects/source/devel/lemon/


I've already posted the file there for you.

--Chris
Comment 3 Yakov Galka 2020-12-23 06:51:33 UTC
Hi, I can confirm that with this patch, plus adding the ipv4 mirror, I can build and install the newer version. However lemon segfaults with default arguments. I think it might not be finding the `lempar.c` at the default location. If I explicitly specify it with -T it works fine though.
Comment 4 Vitaly Magerya 2020-12-23 08:16:18 UTC
Created attachment 220835 [details]
lemon-3.34.diff.txt

Thanks for the mirror, Chris.

And thanks for testing, Yakov. Does this version work better?
Comment 5 Yakov Galka 2020-12-24 00:16:23 UTC
Yes, this works for me. Thank you Vitaly and Chris!
Comment 6 commit-hook freebsd_committer 2021-01-22 11:11:03 UTC
A commit references this bug:

Author: jhale
Date: Fri Jan 22 11:10:09 UTC 2021
New revision: 562294
URL: https://svnweb.freebsd.org/changeset/ports/562294

Log:
  devel/lemon: Update to 3.34

  *While here*
  Add LICENSE. According to [1] it is in the public domain.
  [1] http://www.hwaci.com/sw/lemon/

  PR:		251950
  Submitted by:	Vitaly Magerya <vmagerya@gmail.com> (maintainer)
  Reported by:	Yakov Galka <ybungalobill@gmail.com>

Changes:
  head/devel/lemon/Makefile
  head/devel/lemon/distinfo
Comment 7 Jason E. Hale freebsd_committer 2021-01-22 11:13:14 UTC
Committed, thanks!