Bug 252018 - devel/php-composer: Update to 1.10.19 and create new devel/php-composer2 port for version 2.x
Summary: devel/php-composer: Update to 1.10.19 and create new devel/php-composer2 port...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Guido Falsi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-21 14:49 UTC by Guido Falsi
Modified: 2020-12-21 15:19 UTC (History)
1 user (show)

See Also:
cyberbotx: maintainer-feedback+


Attachments
Composer 1.x update and new 2.x port (3.03 KB, patch)
2020-12-21 14:49 UTC, Guido Falsi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Falsi freebsd_committer 2020-12-21 14:49:40 UTC
Created attachment 220780 [details]
Composer 1.x update and new 2.x port

Hi,

I created a simple update for the php-composer port to the latest version in the 1.x branch.

I also noticed there's been a new 2.x branch out for a while and it also brings a very needed speed boot and ram usage optimization.

Both the update to 1.x and the new 2.x also include fixes related to PHP 8.0.

Can you approve the patch to the 1.x port you maintain?

I set myself as maintainer of the 2.x port because it looked rude to put someone else as maintainer when creating a new port, but if you'd rather maintain both just tell me.

I did choose to create a new port for 2.x because there can be compatibility problems, so having the option to keep using 1.x looks useful.
Comment 1 Naram Qashat 2020-12-21 14:54:08 UTC
I was intending on doing this myself at some point, I just hadn't taken the time to do so. I was aware that composer 2.x is not 100% backwards compatible with 1.x.

I am fine with the patch to the 1.x version, I would prefer to also maintain the 2.x version as well though.

Just a note, it appears you have the 2.x version conflicting with itself.
Comment 2 Guido Falsi freebsd_committer 2020-12-21 15:10:11 UTC
(In reply to Naram Qashat from comment #1)

Thanks for the quick feedback!

Also thanks for spotting my cut&paste error in the new port.

So I'm fixing my mistake and setting you as maintainer for composer2 port too.

Thanks again!
Comment 3 commit-hook freebsd_committer 2020-12-21 15:14:44 UTC
A commit references this bug:

Author: madpilot
Date: Mon Dec 21 15:14:39 UTC 2020
New revision: 558835
URL: https://svnweb.freebsd.org/changeset/ports/558835

Log:
  Update php-composer to 1.10.19.

  Also add CONFLICTS for upcoming version 2.x port.

  PR:		252018
  Approved by:	Naram Qashat <cyberbotx@cyberbotx.com>

Changes:
  head/devel/php-composer/Makefile
  head/devel/php-composer/distinfo
Comment 4 commit-hook freebsd_committer 2020-12-21 15:18:46 UTC
A commit references this bug:

Author: madpilot
Date: Mon Dec 21 15:18:37 UTC 2020
New revision: 558836
URL: https://svnweb.freebsd.org/changeset/ports/558836

Log:
  Create port for new php-composer 2.x branch. (repocopied from
  php-composer)

  This new version includes optimizations for ram usage and a notable
  speedup.

  If you still need the old 1.x version for compatibility reasons
  that's available in the devel/php-composer port.

  upstream announcement: https://blog.packagist.com/composer-2-0-is-now-available/

  Set same maintainer of php-composer at his request

  PR:		252018
  Approved by:	Naram Qashat <cyberbotx@cyberbotx.com> (maintainer)

Changes:
  head/devel/Makefile
  head/devel/php-composer2/
  head/devel/php-composer2/Makefile
  head/devel/php-composer2/distinfo
Comment 5 Guido Falsi freebsd_committer 2020-12-21 15:19:24 UTC
Committed. Thanks!