Bug 252050 - www/nginx: http_push module update
Summary: www/nginx: http_push module update
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Jochen Neumeister
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-22 11:49 UTC by me
Modified: 2021-01-09 11:01 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (joneum)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description me 2020-12-22 11:49:28 UTC
http_push module (github.com/slact/nchan) fails to load at runtime.  Bumping it to the latest version (v1.2.7) and removing the patch allows it to load and work successfully.
Comment 1 commit-hook freebsd_committer 2020-12-23 20:13:11 UTC
A commit references this bug:

Author: joneum
Date: Wed Dec 23 20:12:09 UTC 2020
New revision: 559021
URL: https://svnweb.freebsd.org/changeset/ports/559021

Log:
  Update 3rd party Module nchan

  PR:		252050
  Sponsored by:	Netzkommune GmbH

Changes:
  head/www/nginx/Makefile
  head/www/nginx/Makefile.extmod
  head/www/nginx/distinfo
  head/www/nginx/files/extra-patch-nchan-store-private.h
  head/www/nginx/files/extra-patch-nchan-store-redis-redis_lua_commands.h
Comment 2 Jochen Neumeister freebsd_committer 2020-12-23 20:13:25 UTC
Thx for the Report :-)
I have edited the existing patch and added a new one
Comment 3 me 2020-12-24 15:02:44 UTC
Appreciate the quick reply, thanks! :)  
  
I just built and upgraded to 1.18.0_43,2.  Unfortunately I'm still getting the same error as before, which is as follows...  

```  

> sudo service nginx restart
Performing sanity check on nginx configuration:
nginx: [emerg] dlopen() "/usr/local/libexec/nginx/ngx_nchan_module.so" failed (/usr/local/libexec/nginx/ngx_nchan_module.so: Undefined symbol "memstore_worker_generation") in /usr/local/etc/nginx/nginx.conf:1
nginx: configuration file /usr/local/etc/nginx/nginx.conf test failed

```  
  
I haven't looked at the port sources/patches yet, but is the patch still necessary?  I did manage to compile it without the patch and it worked fine.  It appears that the FreeBSD-specific issue was fixed in version 1.2.4 (See: https://github.com/slact/nchan/blob/master/changelog.txt#L22)  
  
Unless I'm screwing something up on my end, in which case feel free to correct me.  Thanks!
Comment 4 me 2020-12-31 01:48:23 UTC
Re-opened to fix the patching issue.  It seems that the upstream master branch has the port patch changes in it, though it doesn't look like it has been released yet.  
  
Oddly enough, if I build the port without the patches being applied, nchan works fine.
  
As it currently stands, it seems the patches aren't needed anymore?
Comment 5 Jochen Neumeister freebsd_committer 2021-01-05 13:51:19 UTC
Without the patches, there are definitely problems with FreeBSD Current
Comment 6 me 2021-01-09 11:01:44 UTC
Hmm, interesting.  I haven't tried it on -CURRENT yet.  It works for 12.2-RELEASE without patches.  At least for me it does anyway.
  
What error(s) are you getting without the patches on -CURRENT?  That might help me to figure it out when I try to re-compile on both -RELEASE and -CURRENT.  Are they compile-time errors or run-time errors?  I was getting a run-time error when trying to load the module.