Bug 252068 - databases/cassandra4: fix aarch64/arm64 build (javadoc fails)
Summary: databases/cassandra4: fix aarch64/arm64 build (javadoc fails)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-23 13:31 UTC by Ronald Klop
Modified: 2021-02-05 19:54 UTC (History)
3 users (show)

See Also:
language.devel: maintainer-feedback+


Attachments
svn diff (1002 bytes, patch)
2020-12-23 13:31 UTC, Ronald Klop
ronald-lists: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald Klop 2020-12-23 13:31:17 UTC
Created attachment 220840 [details]
svn diff

Increase maxmem of javadoc.
On amd64 this didn't fail, but arm64 fails.

aarch64 failure:
http://ampere1.nyi.freebsd.org/data/121arm64-quarterly/557407/logs/errors/cassandra4-4.0.b1.log  (ipv6 only)
http://ampere2.nyi.freebsd.org/data/head-arm64-default/p557699_s368500/logs/errors/cassandra4-4.0.b2.log  (ipv6 only)

amd64 succes:
http://beefy18.nyi.freebsd.org/data/head-amd64-default/p558707_s368819/logs/cassandra4-4.0.b2.log  (ipv6 only)

The increased memory on arm64 is probably because it does not use the hotspot JIT on openjdk8. Anyways, this small patch fixes it.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2020-12-23 15:44:58 UTC
^Triage: remove patch Keyword.

We now derive whether or not a patch is contained via the [x] Patch checkbox in the diff itself.  Using the metadata like this turns out to be a lot more consistent than relying on the manual effort to set the Keyword.
Comment 2 Angelo Polo 2020-12-26 13:31:23 UTC
Comment on attachment 220840 [details]
svn diff

Approve.
Comment 3 Kurt Jaeger freebsd_committer 2020-12-28 21:15:31 UTC
testbuild @ work
Comment 4 Kurt Jaeger freebsd_committer 2020-12-30 10:33:52 UTC
(In reply to Kurt Jaeger from comment #3)
a testbuild fails with:

find: /bin/sh: Argument list too long

See https://people.freebsd.org/~pi/logs/cassandra4-4.0.b2.log
Comment 5 Ronald Klop 2020-12-30 20:05:02 UTC
(In reply to Kurt Jaeger from comment #4)
It works for me.
https://www.klop.ws/cassandra4.0.b2-13arm64-local-workstation.log

So, where is the error?

My fix in this issue helped your and my build to continue past the javadoc stage so there is progress already.
The build error on your system is not on my RPI4 and not on any other arch which builds cassandra4 [1]. I don't see how my patch would create this error. 

In your log the "data seg size" 131072 in "--Resource limits--" seems a lot smaller than on my machine and on the amd64 beefy18 builder. Could that be the cause of "/bin/sh argument list too long"? But I'm guessing here. It was one of the small differences I notices when diffing your and my build log.

[1] http://beefy18.nyi.freebsd.org/data/head-amd64-default/p558707_s368819/logs/cassandra4-4.0.b2.log
Comment 6 Kurt Jaeger freebsd_committer 2020-12-31 12:56:36 UTC
(In reply to Ronald Klop from comment #5)
I do not know where the resource limit is coming from or if raising it will fix the build. I'll ask on -arm@
Comment 7 Ronald Klop 2021-01-22 13:39:16 UTC
(In reply to Kurt Jaeger from comment #6)
Hi Kurt, any news on the build failure in your qemu/arm64 setup?
Comment 8 Ronald Klop 2021-02-05 17:00:44 UTC
I setup a RPI4 Jenkins server at home. It creates clean jails and runs poudriere in the clean jail.
Build fails without the patch and succeeds with the patch.

Anybody interested in committing this to fix the build on ARM64.
It has no regression on other platforms.
Comment 9 Kurt Jaeger freebsd_committer 2021-02-05 19:53:58 UTC
Committed, thanks!
Comment 10 commit-hook freebsd_committer 2021-02-05 19:54:55 UTC
A commit references this bug:

Author: pi
Date: Fri Feb  5 19:53:56 UTC 2021
New revision: 564149
URL: https://svnweb.freebsd.org/changeset/ports/564149

Log:
  databases/cassandra4: fix aarch64/arm64 build (javadoc fails)

  - Increase maxmem of javadoc
    On amd64 the build does not fail, but on arm64 it fails.

  PR:		252068
  Submitted by:	Ronald Klop <ronald-lists@klop.ws>
  Approved by:	language.devel@gmail.com (maintainer)

Changes:
  head/databases/cassandra4/files/patch-build.xml