Bug 252117 - devel/py-llfuse: Update to 1.3.8
Summary: devel/py-llfuse: Update to 1.3.8
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-12-24 21:44 UTC by John Hein
Modified: 2021-01-10 01:51 UTC (History)
1 user (show)

See Also:
koobs: merge-quarterly?


Attachments
[patch] update py-llfuse to 1.3.8 (1.33 KB, application/x-troff-man)
2020-12-24 21:44 UTC, John Hein
jcfyecrayz: maintainer-approval?
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Hein 2020-12-24 21:44:56 UTC
Created attachment 220901 [details]
[patch] update py-llfuse to 1.3.8

1.3.8 was released in October, 2020.

It supports python3.9 - 1.3.6 fails at build time with python3.9.  See the upstream report regarding that issue:

https://github.com/python-llfuse/python-llfuse/issues/24

Differences from Changes.rst:

Release 1.3.8 (2020-10-10)
==========================

* fix compilation on FreeBSD, #28
* export DEVELOPER_MODE=1 can be used to opt in (default is 0), #22
* twine-based pypi-uploading, Qubes OS support for GPG signing,
  see util/sdist-sign and pypi-upload

Release 1.3.7 (2020-10-04)
==========================

* Rebuild with Cython 0.29.21 for Python 3.9 compatibility.


QA:
 - poudriere testport (ok, including testing with python37 & python39)
 - portlint (ok)
Comment 1 Bugzilla Automation freebsd_committer 2020-12-24 21:44:56 UTC
Maintainer informed via mail
Comment 2 John Hein 2020-12-24 21:48:01 UTC
By the way, the patch also changes the RUN_DEPENDS on py-contextlib2 to be only for python2.7 - it's not used for python3.x