Bug 252193 - [NEW PORT] emulators/reicast: Multi-platform Sega Dreamcast emulator
Summary: [NEW PORT] emulators/reicast: Multi-platform Sega Dreamcast emulator
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Max Brazhnikov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-27 06:53 UTC by Timothy Beyer
Modified: 2021-01-03 17:45 UTC (History)
2 users (show)

See Also:


Attachments
emulators_reicast.shar (7.57 KB, text/plain)
2020-12-27 06:53 UTC, Timothy Beyer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Beyer 2020-12-27 06:53:54 UTC
Created attachment 220986 [details]
emulators_reicast.shar

Created new port for the reicast emulator, which compiles properly, but I think has issues on my machines (with Intel based GPUs) that I have tried thus far.  I am releasing it anyway, and have just released a port for the libretro reicast core itself (see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=252192) in case it works well with other GPUs, because I consider it useful to have a working Sega Dreamcast emulator on FreeBSD.

So far, I've tested it with Mars Matrix, which is emulated accurately when it works.  When it doesn't work, I have to restart Xorg, but this may just be an issue with my GPU driver.

Sorry to just sit on this port for several months, but I wanted to test it carefully.

Tested on FreeBSD 12.1-RELEASE:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=252189
Comment 1 Timothy Beyer 2020-12-27 07:32:39 UTC
I forgot to mention that I personally can only get this to run properly with the Dynarec option disabled, but even so, ran at full speed on the game that I tried (it likely wasn't affected as most of Mars Matrix is 2D, but in either case, I would like to get it to a state where it works with Dynarec enabled).  I can talk to the reicast team to find out why this is necessary, as well as why it even with this fix is still so unstable on my machines with Intel graphics that I have tried thus far.

Ultimately, I thought that this should be submitted, because it may work better on other graphics cards (further, the Intel driver on -CURRENT may work much better), and also in case anyone else can improve on this port.