Bug 252300 - editors/xed: update to 2.8.3
Summary: editors/xed: update to 2.8.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Alexey Dokuchaev
URL:
Keywords: patch-ready
Depends on: 252299
Blocks:
  Show dependency treegraph
 
Reported: 2020-12-31 10:22 UTC by Charlie Li
Modified: 2021-01-17 16:55 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments
v1 (7.77 KB, patch)
2020-12-31 10:22 UTC, Charlie Li
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Charlie Li 2020-12-31 10:22:01 UTC
Created attachment 221122 [details]
v1

Not only update to 2.8.3, but also account for xapp dependency renaming and increased version requirement. Maintainer change to gnome@ is suggested, as X-Apps suite is a not-that-optional part of Cinnamon.

I've had this dogfooded way before (and separately from) what is currently in the ports tree. It is repocopied (although not shown in this diff) from editors/pluma, as that is where xed forked from. All options available in the build are provided and confirmed working here.
Comment 1 commit-hook freebsd_committer 2021-01-17 10:37:41 UTC
A commit references this bug:

Author: danfe
Date: Sun Jan 17 10:37:05 UTC 2021
New revision: 561808
URL: https://svnweb.freebsd.org/changeset/ports/561808

Log:
  - Update to version 2.8.4, add `gnome' to CATEGORIES
  - Provide more descriptive COMMENT, fix RUN_DEPENDS
  - Add DOCS option which installs API documentation
  - Amend the port description based on the README.md

  PR:		252300 (based on)
  Submitted by:	Charlie Li

Changes:
  head/editors/xed/Makefile
  head/editors/xed/distinfo
  head/editors/xed/pkg-descr
  head/editors/xed/pkg-plist
Comment 2 Alexey Dokuchaev freebsd_committer 2021-01-17 11:13:50 UTC
Port had been updated to version 2.8.4 with ports r561808, thank you.  Now, I want to address certain issues and shortcomings with your patch, if you don't mind, for the sake of your future submissions.

>-# Created by: ...
While these lines are indeed optional, you must obtain the creator's explicit permission that they're fine with their attribution being removed.

> -LICENSE=	GPLv2+
> +LICENSE=	GPLv2
Per what I read in the source files top comments and `debian/copyright', it is clearly GPLv2 or later.   Why did you change it?

> USES+=python:3.5+ shebangfix
> ...
> SHEBANG_GLOB=	*.py
Support for Python 3.5 had been removed in ports r549062, minimal version is 3.6 now.  Also, it looks like it should be a run-time dependency only (please correct me if I'm wrong).  Now, what is the purpose of `shebangfix'?  I don't see any shebangs in the installed Python scripts:

$ find $wrkdir/stage/ -name \*.py | xargs grep '#!'
$ _

>  USE_LDCONFIG=	yes
>  USE_XORG=	x11
> +
> +USE_LDCONFIG=	yes
> +
COVID-19 social distance rules do not apply to USE_* knobs: not need to separate them with those blank lines, they like being close together. :-)  Also, because of these needless changes, you've inserted second USE_LDCONFIG.

> +GVFS_METADATA_DESC=	GVFS metadata
> +GVFS_MESON_TRUE=	enable_gvfs_metadata
Typically, we optionize things which require particularly heavy, unpopular, or otherwise potentially undesirable dependency(ies).  This is not the case with GVFS metadata, and it's enabled by default in `meson_options.txt', so unless there is a known scenario how having this option enabled can pessimize user experience, its existence is not really warranted.

In general, your diffs are overly and unnecessarily noisy, due to a mix of functional changes (some of which, however, are dubious or even wrong) with gratuitous reordering of the knobs.  This makes it hard to review and reason about.
Comment 3 Charlie Li 2021-01-17 16:28:56 UTC
(In reply to Alexey Dokuchaev from comment #2)
> While these lines are indeed optional, you must obtain the creator's explicit permission that they're fine with their attribution being removed.

I actually had this in my development tree far longer than you have this committed, since the Cinnamon 4.0 cycle. As a result, none of my stuff was based on your work. Thus such an attribution line was inappropriate in that case.

gvfs is indeed optional here and some users do pessimise it, in the same way that polkit gets pessimised.
Comment 4 Charlie Li 2021-01-17 16:55:59 UTC
USES=python:3.5+ was a relic from earlier development cycles when we did have Python 3.5 in ports. It is also a build dependency whenever additional meson build scripts are in play (most upstreams like to invoke python3 directly so we need BINARY_ALIAS to compensate).

You're right about GPLv2+. Although COPYING doesn't make it clear, it's still the LICENSE_FILE.

Porters handbook needs better clarification on what needs spaced and what does not. There is an emphasis on keeping related knobs together, and some USE_ knobs are not related.

USE_GNOME=intltool is already only a build dependency as shown in Mk/Uses/gnome.mk.

To further illustrate that you didn't originally create this port: https://github.com/freebsd/freebsd-ports-gnome/pull/29/commits/aeb13496ac9aa91fce36a2fd278b5e760d63bf2c