Bug 252301 - print/xreader: move to graphics/xreader and update to 2.8.1
Summary: print/xreader: move to graphics/xreader and update to 2.8.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Alexey Dokuchaev
URL:
Keywords: patch-ready
Depends on: 252299
Blocks:
  Show dependency treegraph
 
Reported: 2020-12-31 10:25 UTC by Charlie Li
Modified: 2021-01-16 06:05 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments
v1 (32.00 KB, patch)
2020-12-31 10:25 UTC, Charlie Li
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Charlie Li 2020-12-31 10:25:06 UTC
Created attachment 221123 [details]
v1

Not only update to 2.8.1, but also account for xapp dependency renaming and increased version requirement. Maintainer change to gnome@ is suggested, as X-Apps suite is a not-that-optional part of Cinnamon.

I've had this dogfooded way before (and separately from) what is currently in the ports tree. It is repocopied (although not shown in this diff) from graphics/atril, as that is where xreader forked from, and thus suggested to move categories for consistency. All options available in the build are provided and confirmed working here.
Comment 1 Alexey Dokuchaev freebsd_committer 2021-01-14 06:39:31 UTC
Thanks for the update.  We traditionally put document readers/writers (PostScript, PDF, etc.) in `print' category because it's more specific, and consistency with other tools deems more important than loose ancestral relationship to `graphics/atril'.  Also, `graphics' category is quite overpopulated (and too broad for a reader).
Comment 2 Charlie Li 2021-01-14 08:48:07 UTC
(In reply to Alexey Dokuchaev from comment #1)
If you want to use this argument, then both graphics/atril and graphics/evince need moved to print/. Otherwise this is not consistent with them two, especially given that this forked from atril, which earlier forked from evince. Regardless, print/ is already listed as an additional category for the other two.
Comment 3 Alexey Dokuchaev freebsd_committer 2021-01-14 09:06:15 UTC
(In reply to Charlie Li from comment #2)
> ... both graphics/atril and graphics/evince need moved to print/
Yes, I think they should be, but someone(tm) has to do it. :-)
Comment 4 commit-hook freebsd_committer 2021-01-15 15:24:34 UTC
A commit references this bug:

Author: danfe
Date: Fri Jan 15 15:24:13 UTC 2021
New revision: 561650
URL: https://svnweb.freebsd.org/changeset/ports/561650

Log:
  - Update to version 2.8.3, augment CATEGORIES
  - Add new options: DBUS, DVI, HELP, and T1LIB

  PR:		252301 (based on)
  Submitted by:	Charlie Li

Changes:
  head/print/xreader/Makefile
  head/print/xreader/distinfo
  head/print/xreader/pkg-plist
Comment 5 Alexey Dokuchaev freebsd_committer 2021-01-16 06:05:25 UTC
Committed as ports r561650 with some modifications, thanks:
- LIB_DEPENDS left unchanged: libsecret-1.so:security/libsecret is pulled by
  the KEYRING and libpoppler-glib.so:graphics/poppler-glib by the PDF one;
  why they were placed on global LIB_DEPENDS is unclear
- Unexplained USES compiler:c11 and python:3.5+,build omitted
- Unexplained MESON_ARGS -Dintrospection=true, -Dpixbuf=true, -Dpdf=true
  also omitted
- Options COMICS, PREVIEWER, and THUMBNAILER make little sense as they pull
  no additional dependencies; DEBUG should not be an option, it's a
  user-facing variable