Bug 252354 - sysutils/unetbootin Fails to Build With Synth
Summary: sysutils/unetbootin Fails to Build With Synth
Status: Closed Not Accepted
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-02 18:38 UTC by dal36
Modified: 2021-06-09 00:48 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dal36 2021-01-02 18:38:50 UTC
I'm seeing the error listed below (section: -- Phase: run-depends) when I try to build sysutils/unetbootin with ports-mgmt/synth. This seems to relate to e2fsprogs-libss or e2fsprogs, but note that this port itself has built and installed correctly. Freebsd version is 12.1-RELEASE-p12.

My understanding is that unetbootin doesn't have any build options, but the build options used for e2fsprogs are as follows:
	ALLTESTS       : off
	BASHTESTS      : off
	DOCS           : on
	FUSEFS         : off
	LIBUNWIND      : off
	NLS            : on
	NOTESTS        : off
	PARALLELTESTS  : off
	SLOWTESTS      : off
	SMALLTESTS     : on

Please let me know if there's any further information that I can provide.

--------------------------------------------------------------------------------
--  Phase: run-depends
--------------------------------------------------------------------------------
===>   unetbootin-681 depends on executable: 7z - not found
===>   Installing existing package /packages/All/p7zip-16.02_3.txz
Installing p7zip-16.02_3...
Extracting p7zip-16.02_3: .......... done
===>   unetbootin-681 depends on executable: 7z - found
===>   Returning to build of unetbootin-681
===>   unetbootin-681 depends on executable: syslinux - not found
===>   Installing existing package /packages/All/syslinux-6.03.txz
Installing syslinux-6.03...
`-- Installing mtools-4.0.10_6...
`-- Extracting mtools-4.0.10_6: .......... done
Extracting syslinux-6.03: .......... done
=====
Message from mtools-4.0.10_6:

--
Please verify /usr/local/etc/mtools.conf for your machine.
===>   unetbootin-681 depends on executable: syslinux - found
===>   Returning to build of unetbootin-681
===>   unetbootin-681 depends on executable: mke2fs - not found
===>   Installing existing package /packages/All/e2fsprogs-1.45.6_5.txz
Installing e2fsprogs-1.45.6_5...
`-- Installing e2fsprogs-libblkid-1.45.6_1...
|   `-- Installing e2fsprogs-libuuid-1.45.6...
|   `-- Extracting e2fsprogs-libuuid-1.45.6: .......... done
`-- Extracting e2fsprogs-libblkid-1.45.6_1: .......... done
`-- Installing e2fsprogs-libss-1.45.6...
`-- Extracting e2fsprogs-libss-1.45.6: .......... done
Extracting e2fsprogs-1.45.6_5: 
pkg-static: Fail to create temporary file: /sbin/.pkgtemp.e2fsck.u73wFaCpmbmr:Read-only file system
Extracting e2fsprogs-1.45.6_5... done

Failed to install the following 1 package(s): /packages/All/e2fsprogs-1.45.6_5.txz
*** Error code 1

Stop.
make: stopped in /xports/sysutils/unetbootin
Comment 1 gessel 2021-06-08 23:25:50 UTC
Duplicate of #249284 I think.
Comment 2 Alexey Dokuchaev freebsd_committer 2021-06-09 00:48:50 UTC
> Duplicate of bug #249284 I think.
Indeed, thanks for the pointer.  Technically it's not a duplicate, but we can't really do anything here for this particular port as the problem clearly lies with e2fsprogs.