Bug 252410 - sysutils/iichid: Update to 0.0.5
Summary: sysutils/iichid: Update to 0.0.5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Fernando Apesteguía
URL: https://github.com/wulf7/iichid/relea...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-04 14:41 UTC by Vladimir Kondratyev
Modified: 2021-02-03 01:46 UTC (History)
1 user (show)

See Also:


Attachments
iichid.patch (1.39 KB, patch)
2021-01-27 15:02 UTC, Vladimir Kondratyev
no flags Details | Diff
iichid.0.0.5.patch (1.39 KB, patch)
2021-01-27 15:09 UTC, Vladimir Kondratyev
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kondratyev freebsd_committer 2021-01-04 14:41:12 UTC
- Fix build on recent CURRENT and STABLE after r368774
- Experemental driver for Elan I2C touchpads
- Mostly matches https://reviews.freebsd.org/D27777
Comment 1 Fernando Apesteguía freebsd_committer 2021-01-04 18:04:29 UTC
^Triage: Reporter is committer, assign accordingly.

^Triage: If there is a changelog or release notes URL available for this version, please add it to the URL field.


Thanks!
Comment 2 Vladimir Kondratyev freebsd_committer 2021-01-04 19:01:33 UTC
(In reply to Fernando Apesteguía from comment #1)
> ^Triage: If there is a changelog or release notes URL available
> for this version, please add it to the URL field.

Done
Comment 3 Vladimir Kondratyev freebsd_committer 2021-01-27 15:02:41 UTC
Created attachment 221964 [details]
iichid.patch
Comment 4 Vladimir Kondratyev freebsd_committer 2021-01-27 15:09:20 UTC
Created attachment 221965 [details]
iichid.0.0.5.patch
Comment 5 Vladimir Kondratyev freebsd_committer 2021-01-27 15:09:57 UTC
I did not commit 0.0.4 version to tree due to some regression reports.

Instead of it, I issued bugfixed 0.0.5 version of sysutils/iichid

Please, approve it.
Comment 6 Fernando Apesteguía freebsd_committer 2021-02-01 13:24:42 UTC
(In reply to Vladimir Kondratyev from comment #5)
What is IGNORE_FreeBSD_14?
Comment 7 Vladimir Kondratyev freebsd_committer 2021-02-01 14:08:10 UTC
(In reply to Fernando Apesteguía from comment #6)
> What is IGNORE_FreeBSD_14?
Ignore build on 14-CURRENT since 13-STABLE has been branched about a week ago. 

$ uname -a    
FreeBSD aspire 14.0-CURRENT FreeBSD 14.0-CURRENT #0 aspire-c256266-gc841a1ee5528-dirty: Mon Jan 25 01:28:21 MSK 2021     root@aspire:/usr/obj/usr/src/amd64.amd64/sys/ASPIRE  amd64
Comment 8 Fernando Apesteguía freebsd_committer 2021-02-02 06:40:38 UTC
(In reply to Vladimir Kondratyev from comment #7)
Oh, I missed that, thanks for the clarification.

LGTM.

Do you want me to commit it or do you prefer to do it yourself?
Comment 9 commit-hook freebsd_committer 2021-02-03 01:43:07 UTC
A commit references this bug:

Author: wulf
Date: Wed Feb  3 01:42:41 UTC 2021
New revision: 563856
URL: https://svnweb.freebsd.org/changeset/ports/563856

Log:
  sysutils/iichid: Update to 0.0.5

  - Mostly matches recent base system import
  - Disable build on 14-CURRENT and 13-STABLE
  - Experemental driver for Elan I2C touchpads

  PR:		252410
  Approved by:	fernape

Changes:
  head/sysutils/iichid/Makefile
  head/sysutils/iichid/distinfo
Comment 10 Vladimir Kondratyev freebsd_committer 2021-02-03 01:46:19 UTC
(In reply to Fernando Apesteguía from comment #8)
>Do you want me to commit it or do you prefer to do it yourself?
I have committed it by myself. Thank you.