Bug 252581 - net-im/telegram-desktop: Fails to build after net/libusrsctp update
Summary: net-im/telegram-desktop: Fails to build after net/libusrsctp update
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-11 16:08 UTC by Guido Falsi
Modified: 2021-01-11 19:23 UTC (History)
3 users (show)

See Also:
lwhsu: maintainer-feedback? (henry.hu.sh)


Attachments
patch API usage (1.60 KB, patch)
2021-01-11 16:08 UTC, Guido Falsi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Falsi freebsd_committer 2021-01-11 16:08:13 UTC
Created attachment 221463 [details]
patch API usage

Hi,

Looks like the net/libusrsctp update in r561195 causes telegram-desktop to fail to build due to an API change.

the upstream change at [1] added an argument to a callback which causes a failure.

I'm attaching a patch which fixed it for me.

Thanks!


[1] https://github.com/sctplab/usrsctp/commit/3df8f52f44d6a24407112123aa68c6a24e8158f3
Comment 1 Yuri Victorovich freebsd_committer 2021-01-11 19:22:25 UTC
Committed, thanks!
Comment 2 commit-hook freebsd_committer 2021-01-11 19:23:06 UTC
A commit references this bug:

Author: yuri
Date: Mon Jan 11 19:22:22 UTC 2021
New revision: 561249
URL: https://svnweb.freebsd.org/changeset/ports/561249

Log:
  net-im/telegram-desktop: Fix the build failure caused by net/libusrsctp update

  libusrsctp significantly changed API without bumping SONAME.

  The upstream is notified.

  PR:		252581
  Submitted by:	madpilot

Changes:
  head/net-im/telegram-desktop/Makefile
  head/net-im/telegram-desktop/files/patch-tg__owt_src_media_sctp_sctp__transport.cc