Bug 252599 - accessibility/gammy no longer presents its GUI
Summary: accessibility/gammy no longer presents its GUI
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on: 252692
Blocks:
  Show dependency treegraph
 
Reported: 2021-01-12 04:32 UTC by Graham Perrin
Modified: 2021-01-18 19:41 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (me)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin 2021-01-12 04:32:24 UTC
% date ; uname -v
Tue 12 Jan 2021 04:30:03 GMT
FreeBSD 13.0-CURRENT #75 main-c572-g82397d791: Sun Jan  3 20:00:09 GMT 2021     root@mowa219-gjp4-8570p:/usr/obj/usr/src/amd64.amd64/sys/GENERIC-NODEBUG 
% pkg query '%o %v %R' gammy
accessibility/gammy 0.9.61 FreeBSD
% pkg info gammy | grep stalled
Installed on   : Tue Jan 12 03:17:15 2021 GMT
% 

When I run Gammy, there's no longer a GUI; and nothing in the system tray notification area.
Comment 1 Mina Galić 2021-01-12 10:14:21 UTC
has this been reported upstream yet?

which desktop environment / WM is this?

i have tested this release in LXDE (OpenBox), enlightenment (?) and Plasma

it takes considerable time to start in enlightenment, that much i noticed (and it doesn't have a presence in the system tray, because, well, enlightenment doesn't seem to have a system tray
Comment 2 Graham Perrin 2021-01-12 18:46:04 UTC
KDE Plasma 5. 

I see the change in gamma immediately after gammy runs but no icon in the system tray, and no window.
Comment 3 Mina Galić 2021-01-12 19:23:04 UTC
so, yes, i can reproduce the issue on Plasma 5 as well.

there's this, issue, which is gnome specific:

[Gnome] Tray icon does not appear when running on startup #57 
https://github.com/Fushko/gammy/issues/57

and i think it might be good to open the KDE issue as well.
https://github.com/Fushko/gammy/issues/76
Comment 4 Graham Perrin 2021-01-18 19:41:51 UTC
Fixed in 0.9.62. Thank you!