Bug 252606 - databases/mysqlwsrep57-server: Update to 5.7.32-25.24
Summary: databases/mysqlwsrep57-server: Update to 5.7.32-25.24
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL: http://releases.galeracluster.com/mys...
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2021-01-12 11:09 UTC by devel
Modified: 2021-04-08 11:51 UTC (History)
1 user (show)

See Also:


Attachments
Update to 5.7.32-25.4 (1.36 KB, patch)
2021-01-12 11:09 UTC, devel
devel: maintainer-approval+
Details | Diff
Update to 5.7.32-25.4, PERFSCHM and patch filename fixes (5.67 KB, patch)
2021-01-14 18:34 UTC, devel
devel: maintainer-approval+
Details | Diff
Update to 5.7.32-25.24, Makefile and patch filename fixes (6.81 KB, patch)
2021-01-15 10:46 UTC, devel
no flags Details | Diff
Update to 5.7.32-25.24, Makefile and patch filename fixes (6.06 KB, patch)
2021-01-15 11:17 UTC, devel
devel: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description devel 2021-01-12 11:09:55 UTC
Created attachment 221489 [details]
Update to 5.7.32-25.4

Portlint passes.

Poudriere passes for 11.4, 12.1, 13.0.
Comment 1 Automation User 2021-01-12 15:18:49 UTC
Build and package info is available at https://gitlab.com/swills/freebsd-ports/pipelines/240454043
Comment 2 Fernando Apesteguía freebsd_committer 2021-01-13 12:25:11 UTC
Q/A:  Makefile: [102]: use a tab (not space) after a variable name
 Makefile: PERFSCHM is listed in OPTIONS_DEFINE, but no PORT_OPTIONS:MPERFSCHM appears.
 files/patch-rapid_plugin_group__replication_src_recovery__state__transfer.cc(working: only use characters [-_.a-zA-Z0-9+] for patch or script names.

Is the trailing "(working" right?

Thanks!
Comment 3 devel 2021-01-14 18:34:18 UTC
Created attachment 221573 [details]
Update to 5.7.32-25.4, PERFSCHM and patch filename fixes

Makefile line 102, space -> tab.

Renamed files/patch-rapid_plugin_group__replication_src_recovery__state__transfer.cc(working to files/patch-rapid_plugin_group__replication_src_recovery__state__transfer.cc.

Comparing the Makefile to one in mysql57-server (which should be quite close), I noticed that OPTIONS_SUB=YES was missing. After adding it, PERFSCHEM option become effective. Is this the right way to fix this (instead of adding if PORT_OPTIONS:MPERFSCHEM)?
Comment 4 Fernando Apesteguía freebsd_committer 2021-01-14 19:29:45 UTC
(In reply to devel from comment #3)
Careful, OPTIONS_SUB was already there. You have it now where you added it and three lines below:

OPTIONS_SUB=            YES
OPTIONS_GROUP=          STORAGE
OPTIONS_GROUP_STORAGE=  ARCHIVE BLACKHOLE EXAMPLE FEDERATED INNOBASE PARTITION PERFSCHEMA
OPTIONS_SUB=            YES

I'm sorry I didn't spot this first. The problem is that the option is named PERFSCHEMA but the helpers are PERFSCHM_* _without the trailing A_

That is why portlint complains.

Would you remove the extra OPTIONS_SUB and also rename the option?
Comment 5 devel 2021-01-15 10:46:42 UTC
Created attachment 221590 [details]
Update to 5.7.32-25.24, Makefile and patch filename fixes

Makefile line 102, space -> tab.

Renamed files/patch-rapid_plugin_group__replication_src_recovery__state__transfer.cc(working to files/patch-rapid_plugin_group__replication_src_recovery__state__transfer.cc.

Handle MPERFSCHM option explicitly after .include <bst.port.options.mk> to get rid of portlint warning.

Clean up unused/unsupported FEDERATED option.
Comment 6 devel 2021-01-15 10:57:06 UTC
(In reply to Fernando Apesteguía from comment #4)

Oops, I missed the duplicate OPTIONS_SUB.

For PERFSCHEMA vs PERFSCHM: It seems that they are two different configuration options. The first one controls build options, i.e. whether the perfschema storage engine is built in server or not. The second one is runtime option, passed to files/mysql-server.in via PERFSCHMRC. Decided to handle PERFSCHM option explicitly after .include <bsd.port.options.mk> to get rid of portlint warning.

Seems that the cleanup of FEDERATED in the last patch was too aggressive, need to revise it once more.
Comment 7 devel 2021-01-15 11:17:51 UTC
Created attachment 221591 [details]
Update to 5.7.32-25.24, Makefile and patch filename fixes

Makefile line 102, space -> tab.

Renamed files/patch-rapid_plugin_group__replication_src_recovery__state__transfer.cc(working to files/patch-rapid_plugin_group__replication_src_recovery__state__transfer.cc.

Handle MPERFSCHM option explicitly after .include <bst.port.options.mk> to get rid of portlint warning.
Comment 8 devel 2021-04-08 11:51:14 UTC
Submitted a patch for 5.7.33-25.25 in https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=254876, closing this one.