Bug 252609 - cad/cura: missing run dependency on devel/py-pynest2d
Summary: cad/cura: missing run dependency on devel/py-pynest2d
Status: Closed DUPLICATE of bug 251236
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-12 12:24 UTC by Greg V
Modified: 2021-01-17 21:23 UTC (History)
3 users (show)

See Also:
fernape: maintainer-feedback? (db)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg V 2021-01-12 12:24:40 UTC
% cura
Traceback (most recent call last):
  File "/usr/local/bin/cura", line 25, in <module>
    import pynest2d # @UnusedImport
ModuleNotFoundError: No module named 'pynest2d'


Looks like the package was added, but not the dependency on it.
Comment 1 Torfinn Ingolfsen 2021-01-12 15:25:26 UTC
(In reply to Greg V from comment #0)
with devel/py-pynest2d installed, Cura at least starts up. No GUI shows up, so there is probably more errors to be found.
Comment 2 Torfinn Ingolfsen 2021-01-12 15:34:42 UTC
(In reply to Torfinn Ingolfsen from comment #1)
Oh well, the gui eventually comes up after > 5 minutes.
Comment 3 Greg V 2021-01-12 16:39:06 UTC
(In reply to Torfinn Ingolfsen from comment #2)
That's weird, I never experienced that problem, it always starts up very quickly for me
Comment 4 Diane Bruce freebsd_committer 2021-01-13 23:26:01 UTC
Please see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=251236
missing dependencies will be added once all these updates are finished.
Sorry.
Comment 5 Diane Bruce freebsd_committer 2021-01-17 21:23:42 UTC

*** This bug has been marked as a duplicate of bug 251236 ***