Bug 252611 - cad/PrusaSlicer: update to 2.3.0
Summary: cad/PrusaSlicer: update to 2.3.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Dmitry Marakasov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-12 14:59 UTC by teodorsigaev@gmail.com
Modified: 2021-01-15 12:13 UTC (History)
1 user (show)

See Also:


Attachments
full cad/PrusaSlicer directory (17.12 KB, application/gzip)
2021-01-12 14:59 UTC, teodorsigaev@gmail.com
no flags Details
Diff to previous version of cad/PrusaSlicer (21.22 KB, patch)
2021-01-12 15:00 UTC, teodorsigaev@gmail.com
no flags Details | Diff
full cad/PrusaSlicer directory (17.13 KB, application/gzip)
2021-01-13 15:59 UTC, teodorsigaev@gmail.com
no flags Details
Diff to previous version of cad/PrusaSlicer (21.29 KB, patch)
2021-01-13 15:59 UTC, teodorsigaev@gmail.com
no flags Details | Diff
Improved Patch (23.67 KB, patch)
2021-01-13 22:37 UTC, Dmitry Marakasov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description teodorsigaev@gmail.com 2021-01-12 14:59:20 UTC
Created attachment 221495 [details]
full cad/PrusaSlicer directory

Update to recently released PrusaSlicer v2.3.0.

Now PrusaSlicer use math/cgal port instead of builtin copy because port was updated to required version.
Comment 1 teodorsigaev@gmail.com 2021-01-12 15:00:11 UTC
Created attachment 221496 [details]
Diff to previous version of cad/PrusaSlicer
Comment 2 Maciej Pasternacki 2021-01-13 12:13:59 UTC
I can confirm that it builds for me and works fine, I'm printing a model sliced with PrusaSlicer-2.3.0 right now. Thank you!

`make check-plist` reports that PrusaSlicer/bin/prusa-gcodeviewer (symlink to prusa-slicer) is not added to pkg-plist. Is this intentional?
Comment 3 teodorsigaev@gmail.com 2021-01-13 15:59:19 UTC
Created attachment 221533 [details]
full cad/PrusaSlicer directory

Fixed make check-plist
Comment 4 teodorsigaev@gmail.com 2021-01-13 15:59:48 UTC
Created attachment 221534 [details]
Diff to previous version of cad/PrusaSlicer

Fixed make check-plist
Comment 5 teodorsigaev@gmail.com 2021-01-13 16:01:30 UTC
(In reply to Maciej Pasternacki from comment #2)
> `make check-plist` reports that PrusaSlicer/bin/prusa-gcodeviewer (symlink to prusa-slicer) is not added to pkg-plist. Is this intentional?

No, itsn't intentional, just missed, thank you. Fixed.
Comment 6 Dmitry Marakasov freebsd_committer 2021-01-13 22:37:53 UTC
Created attachment 221546 [details]
Improved Patch

Let me suggest an improved patch.

- Whitespace fixes
- Remove duplicate (most of BUILD_DEPENDS) and unused (gtest, qt-buildtools) depends
- Add missing depends (png, desktop-file-utils)
- Use WX_CONFIG properly
- Support FHS
- Remove bogus post-patch
- Use DATADIR
- Install .desktop files into proper location
- Patch pthread_(get|set)_name_np in a way compatible with 11.x (the patch may be removed after 11.x EoL)
Comment 7 teodorsigaev@gmail.com 2021-01-14 06:45:19 UTC
Thank you! Works for me. But qt5-buildtools dependency wasn't added by me, see https://svnweb.freebsd.org/ports/head/cad/PrusaSlicer/Makefile?revision=534388&view=markup 

And I a bit wonder why do you remove so many BUILD_DEPENDS entries? I'm afraid it will download itself instead of using ports versions if they aren't installed, see ./work/PrusaSlicer-version_2.3.0/deps/deps-unix-common.cmake and I don't think that is desired behavior.
Comment 8 Dmitry Marakasov freebsd_committer 2021-01-14 17:07:52 UTC
(In reply to teodorsigaev@gmail.com from comment #7)
> And I a bit wonder why do you remove so many BUILD_DEPENDS entries?

In fact I only did remove qt5-buildtools and gtest, other BUILD_DEPENDS were just duplicating LIB_DEPENDS or USES items. I've mailed mandree@ regarding qt-buildtools.

> I'm afraid it will download itself instead of using ports versions if they aren't installed, see ./work/PrusaSlicer-version_2.3.0/deps/deps-unix-common.cmake and I don't think that is desired behavior.

These external projects are not used during the build - they are aggregated into `deps` target which may be manually called to fetch and build depends. Also, if fetching during build ever happens, it would be catched by poudriere which prohibits such behavior.
Comment 9 commit-hook freebsd_committer 2021-01-15 00:25:07 UTC
A commit references this bug:

Author: amdmi3
Date: Fri Jan 15 00:24:13 UTC 2021
New revision: 561616
URL: https://svnweb.freebsd.org/changeset/ports/561616

Log:
  - Update to 2.3.0 [1]
  - Some port cleanup [2]
    - Whitespace fixes
    - Remove duplicate and unused depends
    - Add missing depends
    - Use WX_CONFIG properly
    - Support FHS
    - Switch to PORTDATA
    - Install .desktop files into proper location
    - Fix compatibility with 11.x

  PR:		252611
  Submitted by:	teodorsigaev@gmail.com (maintainer) [1], amdmi3 [2]

Changes:
  head/cad/PrusaSlicer/Makefile
  head/cad/PrusaSlicer/distinfo
  head/cad/PrusaSlicer/files/patch-CMakeLists.txt
  head/cad/PrusaSlicer/files/patch-src_libslic3r_Thread.cpp
  head/cad/PrusaSlicer/files/patch-src_slic3r_CMakeLists.txt
  head/cad/PrusaSlicer/files/patch-src_slic3r_GUI_InstanceCheck.cpp
  head/cad/PrusaSlicer/pkg-plist
Comment 10 teodorsigaev@gmail.com 2021-01-15 12:13:03 UTC
Thank you very much!