Bug 252616 - net/samba413: configure does not find zlib
Summary: net/samba413: configure does not find zlib
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Timur I. Bakeyev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-12 20:03 UTC by thomas.apel
Modified: 2021-01-13 13:47 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (timur)


Attachments
Full make and showconfig output (49.89 KB, text/plain)
2021-01-12 20:03 UTC, thomas.apel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description thomas.apel 2021-01-12 20:03:10 UTC
Created attachment 221507 [details]
Full make and showconfig output

Building net/samba413 fails with configure complaining that it cannot find zlib. The port net/samba412 is affected as well. OS is FreeBSD 12.2-RELEASE-p2. Full make and showconfig output is attached.

The relevant part:

thomas@hostname /usr/ports/net/samba413 % sudo make
[...]
Dynconfig[NCALRPCDIR]:                                                            : '/var/run/samba4/ncalrpc' 
Dynconfig[CONFIGFILE]:                                                            : '/usr/local/etc/smb4.conf' 
Dynconfig[LMHOSTSFILE]:                                                           : '/usr/local/etc/lmhosts' 
Dynconfig[SMB_PASSWD_FILE]:                                                       : '/var/db/samba4/private/smbpasswd' 
Checking for 'zlib'                                                               : not found 
The configuration failed
(complete log in /usr/ports/net/samba413/work/samba-4.13.1/bin/config.log)
===>  Script "configure" failed unexpectedly.
Please report the problem to timur@FreeBSD.org [maintainer] and attach the
"/usr/ports/net/samba413/work/samba-4.13.1/bin/config.log" including the
output of the failure of your make command. Also, it might be a good idea to
provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/net/samba413
*** Error code 1

Stop.
make: stopped in /usr/ports/net/samba413
Comment 1 thomas.apel 2021-01-13 11:25:10 UTC
Extra info:

thomas@hostname /usr/ports/net/samba413 % tail -n 15 work/samba-4.13.1/bin/config.log
Dynconfig[LMHOSTSFILE]: 
'/usr/local/etc/lmhosts'
---------------------------------------------------------------------------------
Dynconfig[SMB_PASSWD_FILE]: 
'/var/db/samba4/private/smbpasswd'
---------------------------------------------------------------------------------
Checking for 'zlib'
['/usr/local/bin/pkg-config', '--cflags', '--libs', 'zlib']
err: Package zlib was not found in the pkg-config search path.
Perhaps you should add the directory containing `zlib.pc'
to the PKG_CONFIG_PATH environment variable
Package 'zlib', required by 'virtual:world', not found

not found
from /usr/ports/net/samba413/work/samba-4.13.1: The configuration failed
Comment 2 thomas.apel 2021-01-13 12:25:25 UTC
Update: It looks like the samba ports are innocent. On my system is no /usr/libdata/pkgconfig/zlib.pc. Actually, my system is missing the whole /usr/libdata/pkgconfig directory for some reason.
Comment 3 thomas.apel 2021-01-13 13:46:37 UTC
Fetching the pkgconfig directory from a base.txz archive fixed the issue. Sorry for bothering you. I will close the ticket.