Bug 252628 - multimedia/ffdec: Update to 12.0.0
Summary: multimedia/ffdec: Update to 12.0.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Fernando Apesteguía
URL: https://github.com/jindrapetrik/jpexs...
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2021-01-13 01:32 UTC by Naram Qashat
Modified: 2021-01-16 23:25 UTC (History)
2 users (show)

See Also:


Attachments
ffdec-12.0.0.patch (872 bytes, patch)
2021-01-13 01:32 UTC, Naram Qashat
cyberbotx: maintainer-approval+
Details | Diff
ffdec-12.0.1.patch (872 bytes, patch)
2021-01-15 13:41 UTC, Naram Qashat
cyberbotx: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Naram Qashat 2021-01-13 01:32:50 UTC
Created attachment 221518 [details]
ffdec-12.0.0.patch

* Update to 12.0.0
* Update distinfo

Changelog: https://github.com/jindrapetrik/jpexs-decompiler/releases/tag/version12.0.0

Did not test with poudriere due to no build, but did test check-plist and stage-qa, both passed. Passes portlint.
Comment 1 Automation User 2021-01-13 01:53:54 UTC
Build and package info is available at https://gitlab.com/swills/freebsd-ports/pipelines/240819508
Comment 2 Fernando Apesteguía freebsd_committer 2021-01-13 12:38:52 UTC
^Triage: If there is a changelog or release notes URL available for this version, please add it to the URL field.


Thanks!
Comment 3 Fernando Apesteguía freebsd_committer 2021-01-13 13:17:13 UTC
$ ffdec
Jan 13, 2021 2:09:56 PM com.jpexs.decompiler.flash.gui.View execInEventDispatch
SEVERE: null
java.lang.reflect.InvocationTargetException
        at java.awt.EventQueue.invokeAndWait(EventQueue.java:1349)
        at java.awt.EventQueue.invokeAndWait(EventQueue.java:1324)
        at javax.swing.SwingUtilities.invokeAndWait(SwingUtilities.java:1353)
        at com.jpexs.decompiler.flash.gui.View.execInEventDispatch(View.java:452)
        at com.jpexs.decompiler.flash.gui.Main.main(Main.java:1967)
Caused by: java.lang.IllegalArgumentException: Menu not found: /settings/internalViewer
        at com.jpexs.decompiler.flash.gui.MainFrameRibbonMenu.setMenuEnabled(MainFrameRibbonMenu.java:546)
        at com.jpexs.decompiler.flash.gui.MainFrameMenu.createMenuBar(MainFrameMenu.java:1013)
        at com.jpexs.decompiler.flash.gui.MainFrameRibbon.<init>(MainFrameRibbon.java:69)
        at com.jpexs.decompiler.flash.gui.Main.ensureMainFrame(Main.java:580)
        at com.jpexs.decompiler.flash.gui.Main.showModeFrame(Main.java:1739)
        at com.jpexs.decompiler.flash.gui.Main.lambda$main$3(Main.java:1971)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:301)
        at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
        at java.awt.EventQueue.access$500(EventQueue.java:97)
        at java.awt.EventQueue$3.run(EventQueue.java:709)
        at java.awt.EventQueue$3.run(EventQueue.java:703)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

and java processes start to eat my CPU.

Can you check this actually works? I'm not familiar with this port. Is there another way to launch it?

Thanks!
Comment 4 Naram Qashat 2021-01-13 15:22:48 UTC
Looking into it a little, I am unsure how to fix this. I am not a Java developer, but skimming over the source code on GitHub, it appears that when they removed the options for checking if an internal Flash player should be used or not, they missed one part that relies on a variable that is set when there is no external Flash player available. (Or maybe it was left intentionally?) Unfortunately, I don't know if this is something I can fix for FreeBSD, as with version 12.0.0 of FFDec, they've marked the software as abandoned and won't take new issues and won't fix bugs.
Comment 5 Fernando Apesteguía freebsd_committer 2021-01-13 15:44:19 UTC
(In reply to Naram Qashat from comment #4)
In that case, and since the update does not seem to work, I would mark it as DEPRECATED and wait for it to be peacefully deleted :-)
Comment 6 Naram Qashat 2021-01-15 05:11:51 UTC
So about 19 hours ago, they did release version 12.0.1 of the decompiler that fixes this problem. I probably won't be able to test if it is fixed until after my current poudriere run finishes, though, but I will try to push another patch out soon.
Comment 7 Naram Qashat 2021-01-15 13:41:06 UTC
Created attachment 221598 [details]
ffdec-12.0.1.patch

* Update to 12.0.1
* Update distinfo

Changelog: https://github.com/jindrapetrik/jpexs-decompiler/releases/tag/version12.0.1

Same notes about testing of 12.0.0 apply to this one too.

I am able to confirm that ffdec is now runnable and works as expected.
Comment 8 commit-hook freebsd_committer 2021-01-16 23:24:56 UTC
A commit references this bug:

Author: fernape
Date: Sat Jan 16 23:24:23 UTC 2021
New revision: 561769
URL: https://svnweb.freebsd.org/changeset/ports/561769

Log:
  multimedia/ffdec: Update to 12.0.0

  ChangeLog:
  https://github.com/jindrapetrik/jpexs-decompiler/releases/tag/version12.0.0

  PR:	252628
  Submitted by:	cyberbotx@cyberbotx.com (maintainer)

Changes:
  head/multimedia/ffdec/Makefile
  head/multimedia/ffdec/distinfo
Comment 9 Fernando Apesteguía freebsd_committer 2021-01-16 23:25:20 UTC
Committed,

Thanks!