Bug 252637 - devel/arduino18: arduino-builder can't compile
Summary: devel/arduino18: arduino-builder can't compile
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kyle Evans
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-13 10:54 UTC by Raffeale
Modified: 2021-01-13 15:44 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (kevans)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raffeale 2021-01-13 10:54:05 UTC
when i make arduino-builder i got following information:


===>  Building for arduino-builder-1.3.25_2
(cd /usr/ports/devel/arduino-builder/work/src/arduino.cc;  for t in ./arduino-builder; do  out=$(/usr/bin/basename $(echo ${t} |  /usr/bin/sed -Ee 's/^[^:]*:([^:]+).*$/\1/' -e 's/^\.$/arduino-builder/'));  pkg=$(echo ${t} |  /usr/bin/sed -Ee 's/^([^:]*).*$/\1/' -e 's/^arduino-builder$/./');  echo "===>  Building ${out} from ${pkg}";  /usr/bin/env XDG_DATA_HOME=/usr/ports/devel/arduino-builder/work  XDG_CONFIG_HOME=/usr/ports/devel/arduino-builder/work  HOME=/usr/ports/devel/arduino-builder/work PATH=/usr/ports/devel/arduino-builder/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  CC="cc" CFLAGS="-O2 -pipe  -fstack-protector-strong -fno-strict-aliasing "  CPP="cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector-strong " LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector-strong -fno-strict-aliasing  "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444" CGO_ENABLED=1  CGO_CFLAGS="-I/usr/local/include"  CGO_LDFLAGS="-L/usr/local/lib"  GOARM= GOPATH="/usr/ports/devel/arduino-builder/work"  GOBIN="" /usr/local/bin/go build -v -buildmode=exe -ldflags=-s  -o /usr/ports/devel/arduino-builder/work/bin/${out}  ${pkg};  done)
===>  Building arduino-builder from ./arduino-builder
go: cannot find main module; see 'go help modules'
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/arduino-builder
*** Error code 1
Comment 1 Dmitri Goutnik freebsd_committer 2021-01-13 11:53:12 UTC
(In reply to Raffeale from comment #0)
What does `go version` show? Also please make sure you have recent enough ports tree (at or after r560773).
Comment 2 Raffeale 2021-01-13 15:44:30 UTC
i fount the problem is go lang , i use devel go lang , so i got compile error message. i just remove devel go lang and install go lang , compilation is ok!