Bug 252701 (gtk-doc-1.33.1) - [exp-run] Update textproc/gtk-doc to 1.33.1
Summary: [exp-run] Update textproc/gtk-doc to 1.33.1
Status: Closed FIXED
Alias: gtk-doc-1.33.1
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dima Panov
URL:
Keywords:
: 252769 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-01-15 04:35 UTC by Dima Panov
Modified: 2021-01-20 15:12 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (desktop)
antoine: exp-run+


Attachments
Update textproc/gtk-doc to 1.33.1 (3.59 KB, patch)
2021-01-15 04:35 UTC, Dima Panov
no flags Details | Diff
Unbreak devel/libdbusmenu with new gtk-doc (4.06 KB, patch)
2021-01-15 04:36 UTC, Dima Panov
no flags Details | Diff
Update textproc/gtk-doc to 1.33.1 v2 (3.94 KB, patch)
2021-01-17 17:41 UTC, Dima Panov
no flags Details | Diff
Update textproc/gtk-doc to 1.33.1 v3 (5.87 KB, patch)
2021-01-17 18:22 UTC, Dima Panov
no flags Details | Diff
Unreak x11/keybinder with new gtk-doc (1.38 KB, patch)
2021-01-20 07:20 UTC, Dima Panov
no flags Details | Diff
Unbreak x11/keybinder with new gtk-doc v2 (1.98 KB, patch)
2021-01-20 07:35 UTC, Dima Panov
no flags Details | Diff
Unbreak x11/cinnamon with new gtk-doc (2.45 KB, patch)
2021-01-20 12:01 UTC, Dima Panov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dima Panov freebsd_committer 2021-01-15 04:35:51 UTC
Created attachment 221585 [details]
Update textproc/gtk-doc to 1.33.1

Hello!

desktop@ would like to ask for an exp-run to upgrade textproc/gtk-doc to 1.33.1 release

patches for gtk-doc itseld and affected devel/libdbusmenu in attachments
Comment 1 Dima Panov freebsd_committer 2021-01-15 04:36:32 UTC
Created attachment 221586 [details]
Unbreak devel/libdbusmenu with new gtk-doc
Comment 2 Dima Panov freebsd_committer 2021-01-17 16:20:17 UTC
*** Bug 252769 has been marked as a duplicate of this bug. ***
Comment 3 Dima Panov freebsd_committer 2021-01-17 17:41:23 UTC
Created attachment 221680 [details]
Update textproc/gtk-doc to 1.33.1 v2

- Depends on hightlight was dropped upstream
- Restore path for *.cmake install
- Add libxml2 dependency
Comment 4 Dima Panov freebsd_committer 2021-01-17 18:22:05 UTC
Created attachment 221683 [details]
Update textproc/gtk-doc to 1.33.1 v3

Switch to meson build
Comment 6 Dima Panov freebsd_committer 2021-01-20 07:20:26 UTC
Created attachment 221756 [details]
Unreak x11/keybinder with new gtk-doc
Comment 7 Dima Panov freebsd_committer 2021-01-20 07:21:04 UTC
(In reply to Antoine Brodin from comment #5)
patch for libdbusmenu was alredy attached :)
Comment 8 Dima Panov freebsd_committer 2021-01-20 07:35:36 UTC
Created attachment 221757 [details]
Unbreak x11/keybinder with new gtk-doc v2

Forgot about plist :(
Comment 10 Dima Panov freebsd_committer 2021-01-20 12:01:24 UTC
Created attachment 221765 [details]
Unbreak x11/cinnamon with new gtk-doc
Comment 11 Antoine Brodin freebsd_committer 2021-01-20 14:19:38 UTC
Exp-run looks fine
Comment 12 commit-hook freebsd_committer 2021-01-20 15:09:01 UTC
A commit references this bug:

Author: fluffy
Date: Wed Jan 20 15:08:51 UTC 2021
New revision: 562141
URL: https://svnweb.freebsd.org/changeset/ports/562141

Log:
  textproc/gtk-doc: update to 1.33.1

  - Switch to meson build (thanks to daniel engberg)
  - Patch affected ports

  PR:		252701
  Exp-run by:	antoine
  MFH:		2021Q1

Changes:
  head/devel/libdbusmenu/Makefile
  head/devel/libdbusmenu/files/patch-docs_libdbusmenu-glib_reference_libdbusmenu-glib-docs.sgml
  head/devel/libdbusmenu/files/patch-docs_libdbusmenu-gtk_reference_libdbusmenu-gtk-docs.sgml
  head/devel/libdbusmenu/pkg-plist
  head/textproc/gtk-doc/Makefile
  head/textproc/gtk-doc/distinfo
  head/textproc/gtk-doc/files/
  head/textproc/gtk-doc/files/patch-help_manual_LINGUAS
  head/textproc/gtk-doc/files/patch-meson.build
  head/textproc/gtk-doc/pkg-plist
  head/x11/cinnamon/Makefile
  head/x11/cinnamon/pkg-plist
  head/x11/keybinder/Makefile
  head/x11/keybinder/files/patch-docs_keybinder-docs.sgml
  head/x11/keybinder/pkg-plist
Comment 13 commit-hook freebsd_committer 2021-01-20 15:12:02 UTC
A commit references this bug:

Author: fluffy
Date: Wed Jan 20 15:11:04 UTC 2021
New revision: 562142
URL: https://svnweb.freebsd.org/changeset/ports/562142

Log:
  MFH: r562141

  textproc/gtk-doc: update to 1.33.1

  - Switch to meson build (thanks to daniel engberg)
  - Patch affected ports

  PR:		252701
  Exp-run by:	antoine

Changes:
_U  branches/2021Q1/
  branches/2021Q1/devel/libdbusmenu/Makefile
  branches/2021Q1/devel/libdbusmenu/files/patch-docs_libdbusmenu-glib_reference_libdbusmenu-glib-docs.sgml
  branches/2021Q1/devel/libdbusmenu/files/patch-docs_libdbusmenu-gtk_reference_libdbusmenu-gtk-docs.sgml
  branches/2021Q1/devel/libdbusmenu/pkg-plist
  branches/2021Q1/textproc/gtk-doc/Makefile
  branches/2021Q1/textproc/gtk-doc/distinfo
  branches/2021Q1/textproc/gtk-doc/files/
  branches/2021Q1/textproc/gtk-doc/pkg-plist
  branches/2021Q1/x11/cinnamon/Makefile
  branches/2021Q1/x11/cinnamon/pkg-plist
  branches/2021Q1/x11/keybinder/Makefile
  branches/2021Q1/x11/keybinder/files/patch-docs_keybinder-docs.sgml
  branches/2021Q1/x11/keybinder/pkg-plist
Comment 14 Dima Panov freebsd_committer 2021-01-20 15:12:37 UTC
Landed!