Bug 252766 - Making graphics/instant-meshes depend on onetbb
Summary: Making graphics/instant-meshes depend on onetbb
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Ganael LAPLANCHE
URL:
Keywords:
Depends on:
Blocks: 252648
  Show dependency treegraph
 
Reported: 2021-01-17 08:04 UTC by Ganael LAPLANCHE
Modified: 2021-01-20 21:35 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (greg)
martymac: maintainer-feedback? (greg)


Attachments
instant-meshes-tbb.patch (6.69 KB, patch)
2021-01-19 13:35 UTC, Greg V
greg: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ganael LAPLANCHE freebsd_committer 2021-01-17 08:04:17 UTC
Hello,

As a maintainer of graphics/instant-meshes, could you have a look at PR #252648:

  https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=252648

In short, TBB version 2021 will soon be available as devel/onetbb but the port you maintain does not build correctly with it, see the following Poudriere run:

  http://box.martymac.org/FreeBSD-Packages/build.html?mastername=FBSD122amd64-tbb-migr&build=2021-01-13_22h35m17s

and error logs:

http://box.martymac.org/FreeBSD-Packages/data/FBSD122amd64-tbb-migr/2021-01-15_15h54m22s/logs/errors/instant-meshes-0.0.42_10.log

/wrkdirs/usr/ports/graphics/instant-meshes/work/instant-meshes-0.0-42-g4a083f4/src/main.cpp:173:29: error: expected ';' after expression
    tbb::task_scheduler_init init(nprocs == -1 ? tbb::task_scheduler_init::automatic : nprocs);
                            ^
                            ;
/wrkdirs/usr/ports/graphics/instant-meshes/work/instant-meshes-0.0-42-g4a083f4/src/main.cpp:173:10: error: no member named 'task_scheduler_init' in namespace 'tbb'
    tbb::task_scheduler_init init(nprocs == -1 ? tbb::task_scheduler_init::automatic : nprocs);
    ~~~~~^
/wrkdirs/usr/ports/graphics/instant-meshes/work/instant-meshes-0.0-42-g4a083f4/src/main.cpp:173:55: error: no member named 'task_scheduler_init' in namespace 'tbb'
    tbb::task_scheduler_init init(nprocs == -1 ? tbb::task_scheduler_init::automatic : nprocs);
                                                 ~~~~~^
3 errors generated.


Could you try to provide a patch (important: *by replying to this PR*) to facilitate the migration to devel/onetbb ?

To help you modifying your port, expected patches to devel/tbb and devel/onetbb are available in PR #252648.

You will also need suitesparse patches from PR #252651 as suitesparse does not build with oneTbb.

Thanks for your contribution,
Best regards,

Ganael.
Comment 1 Greg V 2021-01-19 13:35:06 UTC
Created attachment 221739 [details]
instant-meshes-tbb.patch

Looks like the removed task API is about the only thing it uses from TBB.
Let's just stop unbundling and use the bundled (CMake-ified fork of) TBB as intended. Builds very quickly actually.
Comment 2 Ganael LAPLANCHE freebsd_committer 2021-01-19 15:08:45 UTC
Hello,

Thanks, I'll test and (if OK) commit the patch during the big switch.

Best regards,

Ganael.
Comment 3 Greg V 2021-01-19 15:35:05 UTC
(In reply to Ganael LAPLANCHE from comment #2)
This one can actually go in early, since it removes the dependency altogether
Comment 4 commit-hook freebsd_committer 2021-01-20 11:38:24 UTC
A commit references this bug:

Author: martymac
Date: Wed Jan 20 11:38:16 UTC 2021
New revision: 562132
URL: https://svnweb.freebsd.org/changeset/ports/562132

Log:
  Use internal tbb to facilitate oneTbb transition

  PR:		252766
  Submitted by:	greg@unrelenting.technology
  Approved by:	greg@unrelenting.technology (maintainer)

Changes:
  head/graphics/instant-meshes/Makefile
  head/graphics/instant-meshes/distinfo
  head/graphics/instant-meshes/files/patch-CMakeLists.txt
Comment 5 Ganael LAPLANCHE freebsd_committer 2021-01-20 11:39:01 UTC
Great, I have committed the changes, then.

Thanks again :)