Bug 252769 - textproc/gtk-doc: Update to 1.33.1, use Meson
Summary: textproc/gtk-doc: Update to 1.33.1, use Meson
Status: Closed DUPLICATE of bug 252701
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-desktop (Team)
URL: https://gitlab.gnome.org/GNOME/gtk-do...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-17 09:36 UTC by daniel.engberg.lists
Modified: 2021-01-17 16:51 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (desktop)


Attachments
Patch for gtk-doc (6.71 KB, patch)
2021-01-17 09:36 UTC, daniel.engberg.lists
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description daniel.engberg.lists 2021-01-17 09:36:53 UTC
Created attachment 221661 [details]
Patch for gtk-doc

Update gtk-doc to 1.33.1
Switch to Meson
Disable docs for now, pulls in quite a bit of extra deps and localized variants doesn't build properly due to limitations of meson build script.

Compile and run-tested on FreeBSD 13.0-CURRENT main-c1-g63f93c7e1 (amd64) (make, make check-plist)
Poudriere testport OK 12.2-RELEASE (amd64)
Poudriere testport OK 11.4-RELEASE (amd64)
Comment 1 Dima Panov freebsd_committer 2021-01-17 16:20:17 UTC
Please check for duplicates before submit.
See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=252701

Switch to meson will reasonable after pass submitted exp-run with old-way build and resolve docs builds under meson buildsystem

*** This bug has been marked as a duplicate of bug 252701 ***
Comment 2 daniel.engberg.lists 2021-01-17 16:51:15 UTC
Hi, I didn't see that PR before submitting :/

The patch submitted for exp-run is slightly incorrect according upstream

As of 1.30 highlight isn't needed
https://gitlab.gnome.org/GNOME/gtk-doc/-/blob/master/NEWS#L57

lib/cmake/GtkDoc seems to be the proper path not share/cmake/GtkDoc looking at other ports

libxml2 is listed as a requirement for XML output
https://gitlab.gnome.org/GNOME/gtk-doc/-/blob/master/README

As for the manual, it installs fdl-appendix.xml and index.docbook but no translation because there's no LINGUAS fine. I can enable that again if it's preferred.