Bug 252773 - x11-toolkits/qt5-gui: Segfault on applications using qt5
Summary: x11-toolkits/qt5-gui: Segfault on applications using qt5
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-17 11:08 UTC by BERTRAND Joël
Modified: 2021-01-17 20:29 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (kde)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BERTRAND Joël 2021-01-17 11:08:00 UTC
Hello,

This bug is related to bug #247991.

I have upgraded my system to last 12.2 and last ports with the same result. All qt5 applications crash with Segmentation fault (DRI2) or Bus error (DRI3+SNA).

I have tried to rebuild qt5 (5.15.0) from sources to have debug symbol, backtrace is :

(gdb) bt
#0  0x000000080163fa20 in qt_memfillXX_avx2(unsigned char*, long long
__vector(4), long long) () from /root/qt5/lib/libQt5Gui.so.5
#1  0x00000008018bc2d5 in fillRect_normalized(QRect const&, QSpanData*,
QRasterPaintEnginePrivate*) () from /root/qt5/lib/libQt5Gui.so.5
#2  0x00000008018bdcd6 in QRasterPaintEngine::fillRect(QRectF const&,
QSpanData*) () from /root/qt5/lib/libQt5Gui.so.5
#3  0x00000008018e1a9c in QPainter::fillRect(QRect const&, QBrush const&) ()
   from /root/qt5/lib/libQt5Gui.so.5
#4  0x00000008010c04be in fillRegion(QPainter*, QRegion const&, QBrush
const&)
    () from /root/qt5/lib/libQt5Widgets.so.5
#5  0x00000008010c017f in QWidgetPrivate::paintBackground(QPainter*,
QRegion const&, QFlags<QWidgetPrivate::DrawWidgetFlag>) const ()
   from /root/qt5/lib/libQt5Widgets.so.5

Similar issue with qt5 5.14.2. Of course, I have tried to rebuilt qt5 with different build options without any success. My graphic adapter is internal GPU of a i5-4570S CPU.

xorg.conf :
        Identifier  "Card0"
        Driver      "intel"
        BusID       "PCI:0:2:0"
        Option      "AccelMethod"   "SNA"
        Option      "DRI"           "3"
EndSection


Regards,

JKB
Comment 1 VVD 2021-01-17 13:01:14 UTC
(In reply to BERTRAND Joël from comment #0)
Current version of qt is 5.15.2 now.
Comment 2 BERTRAND Joël 2021-01-17 20:29:49 UTC
Now, this workstation runs with 5.15.2 and I see exactly the same issue. I have tried with intel and modesetting drivers. Same result.

This workstation is a diskless one but I'm not sure this information is relevant.

Best regards,

JKB