Bug 252786 - Making math/openturns depend on onetbb
Summary: Making math/openturns depend on onetbb
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks: 252648
  Show dependency treegraph
 
Reported: 2021-01-17 18:39 UTC by Ganael LAPLANCHE
Modified: 2021-02-19 21:09 UTC (History)
1 user (show)

See Also:
yuri: maintainer-feedback+
yuri: maintainer-feedback+


Attachments
Suggested patch (628 bytes, patch)
2021-01-17 18:41 UTC, Ganael LAPLANCHE
yuri: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ganael LAPLANCHE freebsd_committer 2021-01-17 18:39:04 UTC
Hello,

As a maintainer of math/openturns, could you have a look at PR #252648:

  https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=252648

In short, TBB version 2021 will soon be available as devel/onetbb and (good news!) the port you maintain seems to build correctly with that new version, see the following Poudriere run:

  http://box.martymac.org/FreeBSD-Packages/build.html?mastername=FBSD122amd64-tbb-migr&build=2021-01-13_22h35m17s

and build log:

http://box.martymac.org/FreeBSD-Packages/data/FBSD122amd64-tbb-migr/2021-01-17_09h08m36s/logs/openturns-1.16_1.log

Can you check the port and see if it is working as intended with the attached patch ?

If yes, please agree with the patch *by replying to this PR* (important), that will help me synchronize the changes.

To help you testing your port, expected patches to devel/tbb and devel/onetbb are available in PR #252648.

You will also need suitesparse patches from PR #252651 as suitesparse does not build with oneTbb.

Thanks for your contribution,
Best regards,

Ganael.
Comment 1 Ganael LAPLANCHE freebsd_committer 2021-01-17 18:41:59 UTC
Created attachment 221684 [details]
Suggested patch
Comment 2 Ganael LAPLANCHE freebsd_committer 2021-01-17 18:44:04 UTC
Sorry, full run URL is the following:

http://box.martymac.org/FreeBSD-Packages/build.html?mastername=FBSD122amd64-tbb-migr&build=2021-01-17_09h08m36s
Comment 3 Yuri Victorovich freebsd_committer 2021-01-17 18:45:23 UTC
Approved if there are no build problems.
Comment 4 Ganael LAPLANCHE freebsd_committer 2021-01-18 11:38:59 UTC
Thanks!
Comment 5 Ganael LAPLANCHE freebsd_committer 2021-02-19 21:09:02 UTC
Committed, thanks!