Bug 252791 - multimedia/kodi: update to 19.0RC1
Summary: multimedia/kodi: update to 19.0RC1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Joseph Mingrone
URL:
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2021-01-18 01:47 UTC by yzrh
Modified: 2021-01-21 08:23 UTC (History)
4 users (show)

See Also:


Attachments
patch (2.59 KB, patch)
2021-01-18 01:47 UTC, yzrh
no flags Details | Diff
testport log (120.03 KB, application/gzip)
2021-01-18 01:49 UTC, yzrh
no flags Details
portlint log (433 bytes, text/plain)
2021-01-18 01:49 UTC, yzrh
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description yzrh 2021-01-18 01:47:47 UTC
Created attachment 221690 [details]
patch

Wayland support by default
Rebase patches
Comment 1 yzrh 2021-01-18 01:49:07 UTC
Created attachment 221691 [details]
testport log
Comment 2 yzrh 2021-01-18 01:49:28 UTC
Created attachment 221692 [details]
portlint log
Comment 3 yzrh 2021-01-18 17:38:02 UTC
(In reply to yzrh from comment #0)

Cage and kodi-standalone are working well.

I couldn't manage to start cage without seatd.
In addition, putting

XDG_RUNTIME_DIR=/tmp; export XDG_RUNTIME_DIR

in $HOME/.profile is necessary for cage to start.
Comment 4 Joseph Mingrone freebsd_committer 2021-01-18 22:17:47 UTC
Thanks for submitting the update.

It fails to configure on 11.4 amd64 with error: 

CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:218 (message):
  Could NOT find VAAPI (missing: VAAPI_libva-wayland_INCLUDE_DIR
  VAAPI_libva-wayland_LIBRARY) (Required is at least version "0.39.0")

Full log: http://pkg.awarnach.mathstat.dal.ca/data/11amd64-default/2021-01-18_14h11m16s/logs/errors/kodi-19.0.r1.log

A suggestion for the future: use the linters portclippy/portfmt from ports-mgmt/portfmt.  They can give helpful suggestions, e.g., for following the 'Order of Variables in Port Makefiles' chapter from the Porter's Handbook.
Comment 5 Joseph Mingrone freebsd_committer 2021-01-19 00:50:19 UTC
The same error occurs on 11.4 i386.  I think our options are to either find a fix for the problem or mark the port only buildable on at least 12.1.
Comment 6 Automation User 2021-01-19 11:04:31 UTC
Build and package info is available at https://gitlab.com/swills/freebsd-ports/pipelines/243512438
Comment 7 Joseph Mingrone freebsd_committer 2021-01-19 14:42:59 UTC
Strange that it builds for Steve's tests.  These are pristine jails that I tested in.  The only thing I can think of is that some options that were set in the past have recently.  I'll re-test after resetting all the options.
Comment 8 Bernhard Froehlich freebsd_committer 2021-01-19 16:03:33 UTC
I can confirm that the patch builds fine on 12.1 and 11.4:

https://ports.bluelife.at/builds/20210119-09:26:24.37724/
Comment 9 commit-hook freebsd_committer 2021-01-19 17:41:11 UTC
A commit references this bug:

Author: jrm
Date: Tue Jan 19 17:40:42 UTC 2021
New revision: 562057
URL: https://svnweb.freebsd.org/changeset/ports/562057

Log:
  multimedia/kodi: Update to version 19.0RC1

  PR:		252791
  Submitted by:	yzrh@noema.org (maintainer)

Changes:
  head/multimedia/kodi/Makefile
  head/multimedia/kodi/distinfo
  head/multimedia/kodi/files/patch-cmake_scripts_freebsd_ArchSetup.cmake
  head/multimedia/kodi/files/patch-xbmc_dbwrappers_mysqldataset.cpp
Comment 10 Joseph Mingrone freebsd_committer 2021-01-19 17:42:39 UTC
(In reply to Bernhard Froehlich from comment #8)
Thanks.  I must have set the options to a dependent port long ago and the default options were later changed.  It built for me now too.  http://pkg.awarnach.mathstat.dal.ca/data/11amd64-default/2021-01-19_10h44m45s/logs/kodi-19.0.r1.log

yzrh@noema.org, sorry for the delay and thanks for submitting.
Comment 11 Bernhard Froehlich freebsd_committer 2021-01-19 20:52:59 UTC
Just for the record. This commit does break most kodi addons. As usual I have prepared patches for the addons that I maintain but it sucks that this happens all the time and I have to cleanup afterwards ...
Comment 12 Joseph Mingrone freebsd_committer 2021-01-19 20:57:27 UTC
Sorry to hear that.  I've been in that position as well and it's not pleasant to have to rush fixes in.  How can we do better in the future?  Maybe a note in multimedia/kodi/Makfile to coordinate with you for future updates?
Comment 13 Bernhard Froehlich freebsd_committer 2021-01-19 21:07:39 UTC
The problem is that there are addons which are maintained by different people and addons are fragile and need to match the kodi version. That makes major updates for kodi a pain because you need to get approvals and patches for all addons before you can commit it.
Comment 14 Daniel Ebdrup Jensen freebsd_committer 2021-01-19 22:29:49 UTC
So what's the solution? 

Have multiple people coordinate with a single maintainer?

Leave it all for one person, risking bus-factor?
Comment 15 yzrh 2021-01-20 01:53:00 UTC
I believe the problem is mostly about pkg-plist.
version.mk was proposed before,  other ports
can simply pump PORTREVISION.  Any ideas?
Comment 16 Bernhard Froehlich freebsd_committer 2021-01-21 08:23:01 UTC
This exact case (19.0beta1 to RC1) was definitely non standard because kodi did change the PVR API for addons which made them incompatible in both ways and resulted in build failures. For non PVR plugins the usual PORTREVISION+pkg-plist dance was enough.

So I also believe a USES=kodi and a mass PORTREVISION bump for all addons will be enough to survive minor version updates. For major version updates it is going to be more work because all addons need to be updated in one go and multiple maintainers need to prepare or approve changes. There should be enough time between kodi beta releases and kodi final release to prepare the kodi update and coordinate with the addon maintainers.