Bug 252792 - www/apache24: poudriere fails due to plist error
Summary: www/apache24: poudriere fails due to plist error
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Bernard Spil
URL: https://reviews.freebsd.org/D28217
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-18 04:14 UTC by Koichiro Iwao
Modified: 2021-02-19 11:59 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (apache)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Koichiro Iwao freebsd_committer 2021-01-18 04:14:50 UTC
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: sbin/ecp.fQXqex4S
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1

Stop.
make: stopped in /usr/ports/www/apache24
=>> Error: check-plist failures detected
build of www/apache24 | apache24-2.4.46 ended at Mon Jan 18 13:13:14 JST 2021
build time: 00:00:35
!!! build failure encountered !!!
[00:01:45] Error: Build failed in phase: check-plist
[00:01:45] Cleaning up
[00:01:45] Unmounting file systems
Comment 1 Koichiro Iwao freebsd_committer 2021-01-18 04:15:21 UTC
I have a patch to solve the issue. Will be submitted shortly.
Comment 2 Koichiro Iwao freebsd_committer 2021-01-18 04:37:35 UTC
I also pet these warnings & errors.

Warning: 'sbin/checkgid' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'sbin/htcacheclean' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'sbin/httpd' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'sbin/rotatelogs' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'sbin/fcgistarter' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Error: /usr/local/bin/ab is linked to /usr/local/lib/libdb-5.3.so.0 from databases/db5 but it is not declared as a dependency
Warning: you need USES+=bdb
Error: /usr/local/bin/ab is linked to /usr/local/lib/libgdbm.so.6 from databases/gdbm but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libgdbm.so:databases/gdbm
Comment 3 Koichiro Iwao freebsd_committer 2021-01-18 04:53:03 UTC
See Phabricator review.
Comment 4 commit-hook freebsd_committer 2021-02-19 11:50:19 UTC
A commit references this bug:

Author: brnrd
Date: Fri Feb 19 11:49:35 UTC 2021
New revision: 566051
URL: https://svnweb.freebsd.org/changeset/ports/566051

Log:
  www/apache24: Change strip behavior

   * Use the dists build/rules.mk method
   * cleanup of left-over files from strip

  PR:		252792
  Submitted by:	meta
  Approved by:	joneum (apache)
  Differential Revision:	https://reviews.freebsd.org/D28217

Changes:
  head/www/apache24/Makefile