Bug 252808 - sysutils/polkit: Install fails on polkitd user creation
Summary: sysutils/polkit: Install fails on polkitd user creation
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-desktop (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-18 16:40 UTC by Jason W. Bacon
Modified: 2021-08-01 15:15 UTC (History)
3 users (show)

See Also:
tcberner: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason W. Bacon freebsd_committer 2021-01-18 16:40:18 UTC
[14/59] Installing polkit-0.118...
===> Creating groups.
Creating group 'polkitd' with gid '565'.
===> Creating users
Creating user 'polkitd' with uid '565'.
pw: user 'polkitd' disappeared during update
pkg: PRE-INSTALL script failed

Quick-fix is run "pwd_mkdb /etc/master.passwd" and rerun the install.

Not really sure if this is a polkit issue or a ports issue.
Comment 1 Tobias C. Berner freebsd_committer 2021-01-21 21:08:02 UTC
Moin moin 

Is this reproducible for you?


mfg Tobias
Comment 2 Tobias C. Berner freebsd_committer 2021-02-12 20:28:18 UTC
Moin moin 

Could you reproduce it?


mfg Tobias
Comment 3 Mikael Urankar freebsd_committer 2021-02-14 14:27:31 UTC
It's probably bug #232921, fixed in base r368713
Comment 4 John Hein 2021-08-01 14:22:06 UTC
No feedback for months, and a likely culprit was described (and fixed since the bug was reported)... this should probably be closed OBE.
Comment 5 Tobias C. Berner freebsd_committer 2021-08-01 14:24:02 UTC
Moin moin 

Please reopen if this is still an issue.


mfg Tobias
Comment 6 Jason W. Bacon freebsd_committer 2021-08-01 15:15:54 UTC
Hmm, didn't see any update notifications for this PR until now.  Indeed I have not seen this issue recently, so it seems to be resolved.