Bug 252817 - multimedia/musikcube: app crashes on startup
Summary: multimedia/musikcube: app crashes on startup
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-19 03:32 UTC by casey langen
Modified: 2021-02-05 02:05 UTC (History)
2 users (show)

See Also:
yuri: maintainer-feedback+


Attachments
patch to fix issue (1000 bytes, patch)
2021-01-21 06:00 UTC, Steve Wills
no flags Details | Diff
updated patch (1009 bytes, patch)
2021-01-21 06:49 UTC, Steve Wills
swills: maintainer-approval? (yuri)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description casey langen 2021-01-19 03:32:57 UTC
Hello, I'm the creator/maintainer of musikcube (https://github.com/clangen/musikcube), but I do not maintain the port.

I recently installed FreeBSD on my system and found the app crashes on startup. After some spelunking around, I found that it seems to be caused by linking against the ncurses library in `/lib`. 

If I go into /usr/local/ports/multimedia/musikcube and remove the following line from the Makefile, then rebuild, all is fine:

CMAKE_ARGS=    -DNCURSES_LIBRARIES="cursesw;tinfow;panelw"

I'm not sure what the difference between the curses library in /lib and /usr/local/lib are, but the former seems to cause problems, so I'd suggest linking against the one in /usr/local/lib
Comment 1 Yuri Victorovich freebsd_committer 2021-01-19 04:26:28 UTC
Thanks for reporting.

The recent change to base ncurses is reverted.
Comment 2 commit-hook freebsd_committer 2021-01-19 04:26:50 UTC
A commit references this bug:

Author: yuri
Date: Tue Jan 19 04:26:22 UTC 2021
New revision: 562022
URL: https://svnweb.freebsd.org/changeset/ports/562022

Log:
  multimedia/musikcube: Fix crash by reverting change to ncurses:base

  ncurses:base causes the application to abort due to the exception.

  PR:		249572 252817
  Reported by:	casey langen <casey.langen@gmail.com>

Changes:
  head/multimedia/musikcube/Makefile
Comment 3 Steve Wills freebsd_committer 2021-01-21 06:00:49 UTC
Created attachment 221778 [details]
patch to fix issue

The version built against base ncurses works fine for me. The problem looks to be r554151, not r561888, which is what was reverted, except for the patch file. I did some testing and was able to reproduce a build issue with base ncurses and without ports ncurses installed and I think this patch solves it while also allowing use of ports ncurses if it's installed.
Comment 4 Steve Wills freebsd_committer 2021-01-21 06:04:21 UTC
See previous patch/comment.
Comment 5 Steve Wills freebsd_committer 2021-01-21 06:49:24 UTC
Created attachment 221779 [details]
updated patch

Sorry, missed a few things, this seems to do it.
Comment 6 Steve Wills freebsd_committer 2021-01-26 16:05:47 UTC
May I commit these changes?
Comment 7 Yuri Victorovich freebsd_committer 2021-01-26 20:47:48 UTC
Please commit.
Comment 8 commit-hook freebsd_committer 2021-02-05 02:04:40 UTC
A commit references this bug:

Author: swills
Date: Fri Feb  5 02:03:39 UTC 2021
New revision: 564074
URL: https://svnweb.freebsd.org/changeset/ports/564074

Log:
  multimedia/musikcube: build with base ncurses

  Fixes issues seen previously with startup crashes with base ncurses

  PR:		252817
  Approved by:	yuri (maintainer)

Changes:
  head/multimedia/musikcube/Makefile
  head/multimedia/musikcube/files/patch-src_musikcube_CMakeLists.txt