Bug 252916 - lang/python37: python3.7-config does not answer to --embed
Summary: lang/python37: python3.7-config does not answer to --embed
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-python (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-22 17:17 UTC by Thierry Thomas
Modified: 2021-01-25 16:32 UTC (History)
1 user (show)

See Also:
kai: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry Thomas freebsd_committer 2021-01-22 17:17:21 UTC
$ python3.7-config --cflags --libs --ldflags --embed
Usage: /usr/local/bin/python3.7-config --prefix|--exec-prefix|--includes|--libs|--cflags|--ldflags|--extension-suffix|--help|--abiflags|--configdir
$ echo $?
1

I get that with Python 3.7.9 (from lang/python37 3.7.9_1).

Without it, french/aster cannot be built.

Is it possible to add it?
Or does it exist some work-around?
Comment 1 commit-hook freebsd_committer 2021-01-24 11:19:20 UTC
A commit references this bug:

Author: thierry
Date: Sun Jan 24 11:19:09 UTC 2021
New revision: 562462
URL: https://svnweb.freebsd.org/changeset/ports/562462

Log:
  - Chase gfortran10 and do not force Gcc any more;

  - Mark french/aster BROKEN untill a solution is found for PR 252916.

  PR:		252916

Changes:
  head/french/aster/Makefile
  head/science/tfel-edf/Makefile
Comment 2 Kai Knoblich freebsd_committer 2021-01-25 11:41:14 UTC
(In reply to Thierry Thomas from comment #0)

It seems that the '--embed' option of the 'python-config' command was first introduced with Python 3.8:

https://github.com/python/cpython/commits/v3.8.7/Misc/python-config.in

It isn't available with Python 3.7:

https://github.com/python/cpython/commits/v3.7.9/Misc/python-config.in

I also looked at a log of french/aster, where it was successfully built (13.0-CURRENT@2ed0c8d80 with Python 3.7.9_1):

http://gohan03.nyi.freebsd.org/data/main-amd64-default-baseline/p559036_s2ed0c8d80/logs/fr-aster-14.6.0.1_2.log

It contains the same notice regarding the missing '--embed' option of 'python-config'. So the lack of the '--embed' option doesn't seem to be the real cause of the build issues as far I can tell.

HTH
Comment 3 Thierry Thomas freebsd_committer 2021-01-25 16:32:33 UTC
Many thanks for the analysis!

It was the only problem in the logs, that's why I thought it was the cause…
but I have to dig more!