Bug 252926 - graphics/mtpaint: Adopt/Update to 3.50
Summary: graphics/mtpaint: Adopt/Update to 3.50
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rainer Hurling
URL: http://mtpaint.sourceforge.net/news.html
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-22 22:35 UTC by Nuno Teixeira
Modified: 2021-01-25 19:52 UTC (History)
4 users (show)

See Also:


Attachments
Sugested git diff (6.85 KB, patch)
2021-01-22 22:35 UTC, Nuno Teixeira
eduardo: maintainer-approval+
Details | Diff
Sugested git diff (complete patch-configure) (6.78 KB, patch)
2021-01-23 07:30 UTC, Nuno Teixeira
eduardo: maintainer-approval+
Details | Diff
Sugested git diff (with correct openjpeg depends) (6.78 KB, patch)
2021-01-23 09:32 UTC, Nuno Teixeira
eduardo: maintainer-approval+
Details | Diff
Sugested git diff (with added WebP option) (6.85 KB, patch)
2021-01-24 04:34 UTC, Nuno Teixeira
eduardo: maintainer-approval+
Details | Diff
patch with latest Github sources and some adaptions (7.68 KB, patch)
2021-01-24 17:32 UTC, Rainer Hurling
eduardo: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nuno Teixeira freebsd_committer 2021-01-22 22:35:56 UTC
Created attachment 221818 [details]
Sugested git diff

Hello,

graphics/mtpaint: Adopt and Update to 3.50 version

- removed files/patch-src_png.c since it is fixed upstream
- add DOCS (README)
- USE_GNOME= gtk30

Thanks,

Nuno Teixeira
Comment 1 Nuno Teixeira freebsd_committer 2021-01-23 07:30:08 UTC
Created attachment 221831 [details]
Sugested git diff (complete patch-configure)
Comment 2 Kurt Jaeger freebsd_committer 2021-01-23 08:24:06 UTC
graphics/openjpeg no longer provides libopenjpeg.so, so:

[cur-default] Installing openjpeg-2.4.0...
[cur-default] Extracting openjpeg-2.4.0: .......... done
===>   mtpaint-3.50 depends on shared library: libopenjpeg.so - not found

Which version of openjpeg would be correct ? openjpeg15 or openjpeg ?
Comment 3 Nuno Teixeira freebsd_committer 2021-01-23 09:31:12 UTC
You're right, libopenjpeg.so is from openjpeg15, but I want openjpeg jp2v2

configure:
jp2v1 ............ Use libopenjpeg
jp2v2 ............ Use libopenjpeg2

I've used:

OPENJPEG_LIB_DEPENDS=   libopenjp2.so:graphics/openjpeg

and it builds ok with it, https://termbin.com/m1yo

% ldd work/stage/usr/local/bin/mtpaint | grep jp2
% libopenjp2.so.7 => /usr/local/lib/libopenjp2.so.7 (0x800328000)

OPENJPEG option OFF and builds ok without it (ldd doesn't show this library), 
https://termbin.com/114o

diff logjp2 lognojp2

---
19c19
< ===>   mtpaint-3.50 depends on shared library: libopenjp2.so - found (/usr/local/lib/libopenjp2.so)
---
> ===>   mtpaint-3.50 depends on shared library: libjasper.so - found (/usr/local/lib/libjasper.so)
68c68
<     Use JPEG 2000       OpenJPEG2
---
>     Use JPEG 2000       JasPer
---

I think this is ok now, could you please test new patch?
Comment 4 Nuno Teixeira freebsd_committer 2021-01-23 09:32:19 UTC
Created attachment 221832 [details]
Sugested git diff (with correct openjpeg depends)
Comment 5 Fernando Apesteguía freebsd_committer 2021-01-23 17:52:09 UTC
This should fetch from GitHub instead of SF:

See https://sourceforge.net/p/mtpaint/discussion/523041/thread/a0fd7b7fbd/?limit=25#1e9d/e00e
Comment 6 Nuno Teixeira freebsd_committer 2021-01-23 18:08:40 UTC
SF master sites works.
GH project doesn't have tags.
Comment 7 Nuno Teixeira freebsd_committer 2021-01-23 18:16:52 UTC
nor releases
Comment 8 Fernando Apesteguía freebsd_committer 2021-01-23 18:24:26 UTC
(In reply to Nuno Teixeira from comment #6)
(In reply to Nuno Teixeira from comment #7)

But we can update to a specific commit, can't we?

Reproducing here what the author of the software says in the link I pasted above:

"The program does receive its updates on Github. It was the additional work of doing a full release that I had long been avoiding."

The GitHub "version" is already in 3.51 as it seems.
Comment 9 Rainer Hurling freebsd_committer 2021-01-23 18:54:20 UTC
(In reply to Fernando Apesteguía from comment #8)
Hi Fernando,

Thanks for the pointer. I will try to build a version 3.51 from Github [1] and see, what happens ;)


[1] https://github.com/wjaguar/mtPaint/tree/master
Comment 10 Nuno Teixeira freebsd_committer 2021-01-24 04:34:03 UTC
Created attachment 221860 [details]
Sugested git diff (with added WebP option)

Add WebP option.

(configure)
----------
File Types
----------

    Use GIF             GIF
    Use JPEG            YES
    Use JPEG 2000       OpenJPEG2
    Use TIFF            YES
    Use WebP            YES

I saved jpeg to webp ok.
Comment 11 Rainer Hurling freebsd_committer 2021-01-24 17:32:35 UTC
Created attachment 221885 [details]
patch with latest Github sources and some adaptions

Hi Nuno,

Based on your latest patch here now my changes for using up to date Github sources.

I decided to number the port/package as 3.50.03 because of this versioning on Github [1]. Because there are no releases, we have to use the hash in GT_TAGNAME.  BTW, the internal version number is already on 3.51, see help in running app ...

What this patch also does (against your last one):

- Remove GIF from CONFIGURE_ARGS, as it is internal now [2]
- Change to MANPREFIX in CONFIGURE_ARGS and in do-install
  target. mtpaint.1 now under man/man1 instead of share/man/man1
- Reorder CONFIGURE_ARGS and OPTIONS_DEFINE a bit
- Add NEWS to PORTDOCS. do-insall-docs-ON has to do it for
  every single file now.
- Add new language 'Kabyle' [3]
- Reorder some Makefile vars (as suggested by portclippy)
- Update distinfo and pkg-plist


[1] https://github.com/wjaguar/mtPaint/commit/40bde4557c254188b2924c90f4a35eef784b0a12
[2] see [1], in file NEWS
[3] https://github.com/wjaguar/mtPaint/commit/f6e8058c117cc11ae4cd5b1b11391d20de7f06cf


If you agree with using this latest version of mtPaint, would you please test a bit and report back?  Many thanks :)
Comment 12 Nuno Teixeira freebsd_committer 2021-01-25 08:27:49 UTC
Comment on attachment 221885 [details]
patch with latest Github sources and some adaptions

Hi,

Looks very nice!

Thanks
Comment 13 Nuno Teixeira freebsd_committer 2021-01-25 08:38:32 UTC
(In reply to Rainer Hurling from comment #11)
Hello,

NLS kab language is not inluded in do-install-NLS-on list.

Else is perfect :)
Comment 14 Nuno Teixeira freebsd_committer 2021-01-25 08:44:43 UTC
(In reply to Rainer Hurling from comment #11)
NLS kab is included. sorry I didn't see it at first look.
Comment 15 Rainer Hurling freebsd_committer 2021-01-25 18:44:46 UTC
(In reply to Nuno Teixeira from comment #12)
Hi Nuno,

FYI: I opened a review on Phabricator [1] to get approval from my mentors :)

[1] https://reviews.freebsd.org/D28336
Comment 16 commit-hook freebsd_committer 2021-01-25 19:49:34 UTC
A commit references this bug:

Author: rhurlin
Date: Mon Jan 25 19:49:27 UTC 2021
New revision: 562607
URL: https://svnweb.freebsd.org/changeset/ports/562607

Log:
  graphics/mtpaint: Update to 3.50.03

  Changelog-like descriptions in each commit since 3.40 [1].

  [1] https://github.com/wjaguar/mtPaint/commits/master

  PR:		252926
  Submitted by:	Nuno Teixeira <ed.arrakis@gmail.com> (new maintainer)
  Approved by:	arrowd (mentor)
  Differential Revision:	https://reviews.freebsd.org/D28336

Changes:
  head/graphics/mtpaint/Makefile
  head/graphics/mtpaint/distinfo
  head/graphics/mtpaint/files/patch-configure
  head/graphics/mtpaint/files/patch-src_png.c
  head/graphics/mtpaint/pkg-plist
Comment 17 Rainer Hurling freebsd_committer 2021-01-25 19:52:10 UTC
Committed, thanks! Have fun :)