Bug 252966 - converters/wkhtmltopdf: failure with HDF5 1.12
Summary: converters/wkhtmltopdf: failure with HDF5 1.12
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks: 251894
  Show dependency treegraph
 
Reported: 2021-01-24 10:10 UTC by Thierry Thomas
Modified: 2021-01-24 10:48 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (pi)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry Thomas freebsd_committer 2021-01-24 10:10:29 UTC
science/hdf5 should be upgraded to 1.12, but some ports are not compatible with this version, and it has been suggested to repocopy the actual port to science/hdf5-110.

PR 251894 proposes a patch to do that, and an exp-run has been launched to detect the incompatibilities.

Unfortunately, your port converters/wkhtmltopdf failed: see
http://package18.nyi.freebsd.org/data/121amd64-default-foo/2021-01-20_21h30m48s/logs/errors/wkhtmltopdf-0.12.6.log

Could you please propose a patch, either to fix it with 1.12 or to switch to hdf5-110?
Comment 1 Kurt Jaeger freebsd_committer 2021-01-24 10:33:01 UTC
I have no idea where the dependency on hdf5 comes into play.

The log under the link you provided does not seem to reference hdf5 ?

I am aware that there are ports-builder builds that fail currently (because I get the fail mails), but I do not yet have an idea why they fail.
Comment 2 Thierry Thomas freebsd_committer 2021-01-24 10:39:19 UTC
Well, if this a false-positive, let's close this PR.
Comment 3 Kurt Jaeger freebsd_committer 2021-01-24 10:48:43 UTC
Closing because reference to hdf5 is not found.