Bug 252983 - Error in Makefile for comms/hackrf-devel
Summary: Error in Makefile for comms/hackrf-devel
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-24 18:49 UTC by Robert William Vesterman
Modified: 2021-01-25 14:07 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert William Vesterman 2021-01-24 18:49:02 UTC
I just went to do a periodic update of my installed ports (using synth) and got this error:

-------------------------
# synth status topLevelPackages.txt
Regenerating flavor index: this may take a while ...
Scanning entire ports tree.
 progress: 6.15%
culprit: comms/hackrf-devel
  Scan aborted because 'make' encounted an error in the Makefile.
  comms/hackrf-devel (return code = 1)
Flavor index generation failed: ports scan
--------------------------

I see hackrf-devel was just updated a few hours ago. I don't use hackrf-devel, or hackrf, and have never even heard of them, so I guess synth scans absolutely everything. So I guess this problem will prevent anyone who uses synth from updating their ports, not just users of hackrf-devel.

I couldn't find any further detail on the error in synth's logs, but eventually I found something on the web related to a similar problem for a different port, which led to me running this command to find the cause:

--------------------------
# make -C /usr/ports/comms/hackrf-devel/ -V PORTNAME
make: "/usr/ports/comms/hackrf-devel//Makefile" line 26: Could not find Makefile.git_rev
make: Fatal errors encountered -- cannot continue
make: stopped in /usr/ports/comms/hackrf-devel/
--------------------------
Comment 1 Bugzilla Automation freebsd_committer 2021-01-24 18:49:02 UTC
Maintainer informed via mail
Comment 2 Robert William Vesterman 2021-01-24 21:20:38 UTC
I see that the change that broke this (ports r562478) has now been reverted (ports r562511) "to unbreak INDEX", but I've since done a "portsnap fetch update" and received the same error.

The comms/hackrf-devel directory was actually created (as a copy of comms/hackrf) in the change that had been reverted, but it still exists on my machine (even after the "portsnap fetch update"). If I do a "pkg search hackrf-devel", it does NOT show up, though, so (if I'm understanding correctly) I guess its entry did get removed from the index, but /usr/ports/comms/hackrf-devel didn't get removed, and synth still checks it (and still gets the same error).

I do not know enough about the low-level details of the ports system to know if any or all of this is expected, or in any case what to do about it. Should I just "rm -rf /usr/ports/comms/hackrf-devel"?
Comment 3 Dmitri Goutnik freebsd_committer 2021-01-25 14:07:43 UTC
Should be fixed by ports r562516 and ports r562519