Bug 253012 - devel/vitables: remove workaround and unbreak after gcc upgrade
Summary: devel/vitables: remove workaround and unbreak after gcc upgrade
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-26 09:06 UTC by Max Brazhnikov
Modified: 2021-01-26 09:40 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (yuri)


Attachments
remove harmful workaround (930 bytes, patch)
2021-01-26 09:06 UTC, Max Brazhnikov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Max Brazhnikov freebsd_committer 2021-01-26 09:06:53 UTC
Created attachment 221925 [details]
remove harmful workaround

vitables fails to start after switching from gcc9 to gcc10. Remove now useless workaround that masked a problem somewhere else.
Comment 1 Yuri Victorovich freebsd_committer 2021-01-26 09:22:43 UTC
Hi Max,

I just tried to start 'vitables' and it had no problems starting and displaying a sample hdf5 file.

Does it crash for you?

Maybe the workaround should be removed, but I can't reproduce the problem.

Yuri
Comment 2 Yuri Victorovich freebsd_committer 2021-01-26 09:40:02 UTC
Committed, thanks!
Comment 3 commit-hook freebsd_committer 2021-01-26 09:40:52 UTC
A commit references this bug:

Author: yuri
Date: Tue Jan 26 09:40:01 UTC 2021
New revision: 562648
URL: https://svnweb.freebsd.org/changeset/ports/562648

Log:
  devel/vitables: Remove unndecessary workaround that was needed for gcc-9-

  PR:		253012
  Submitted by:	makc

Changes:
  head/devel/vitables/Makefile