Bug 253047 - www/mitmproxy 4.0.4_3 fails to build in phase: run-depends
Summary: www/mitmproxy 4.0.4_3 fails to build in phase: run-depends
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2021-01-27 14:54 UTC by p5B2E9A8F
Modified: 2021-03-16 09:42 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gaod)


Attachments
poudriere build log file (16.85 KB, text/plain)
2021-01-27 14:54 UTC, p5B2E9A8F
no flags Details
poudriere build log (16.13 KB, text/plain)
2021-03-12 09:09 UTC, p5B2E9A8F
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description p5B2E9A8F 2021-01-27 14:54:16 UTC
Created attachment 221963 [details]
poudriere build log file

[12amd64-default-jails-job-01] Extracting py38-pyperclip-1.7.0: .......... done
===>   Installing existing package /packages/All/py38-hyperframe-6.0.0.txz
[12amd64-default-jails-job-01] Installing py38-hyperframe-6.0.0...
[12amd64-default-jails-job-01] Extracting py38-hyperframe-6.0.0: .......... done
*** Error code 1

Stop.
=>> Cleaning up wrkdir
build time: 00:00:13
!!! build failure encountered !!!
Comment 1 Fernando Apesteguía freebsd_committer 2021-02-10 06:38:04 UTC
(In reply to p5B2E9A8F from comment #0)

python 3.8?

$ grep PYTHON bsd.default-versions.mk 
        JAVA JULIA LAZARUS LIBRSVG2 LINUX LLVM LUA MYSQL PERL5 PGSQL PHP PYTHON PYTHON2 \
        PYTHON3 RUBY RUST SAMBA SSL TCLTK VARNISH
PYTHON_DEFAULT?=        3.7
PYTHON2_DEFAULT?=       2.7
PYTHON3_DEFAULT?=       3.7
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2021-02-10 09:55:04 UTC
@Reporter 

1) Does www/mitmproxy from an up to date ports tree also fail to build/package/install with @py38 ? If so please provide that build log as an attachment

2) Does the reported failure occur when running the same build with ccache disabled?
Comment 3 p5B2E9A8F 2021-03-12 09:09:18 UTC
Created attachment 223203 [details]
poudriere build log
Comment 4 Michael Zhilin freebsd_committer 2021-03-16 06:36:41 UTC
I confirm same issue for me. 

BTW, let's update it to latest version according to ticket 250799 and close this one.
Comment 5 Hung-Yi Chen 2021-03-16 09:42:17 UTC
Indeed, I think we should focus on ticket 250799.