Bug 253064 - net-mgmt/prometheus2: Update to 2.24.1
Summary: net-mgmt/prometheus2: Update to 2.24.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Dmitri Goutnik
URL:
Keywords: buildisok, patch
: 253053 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-01-28 13:45 UTC by Boris Korzun
Modified: 2021-01-28 23:14 UTC (History)
3 users (show)

See Also:
dor.bsd: maintainer-feedback+


Attachments
prometheus2.diff (11.26 KB, patch)
2021-01-28 13:45 UTC, Boris Korzun
no flags Details | Diff
net-mgmt/prometheus2: Update to 2.24.1 (11.65 KB, patch)
2021-01-28 17:15 UTC, David O'Rourke
dor.bsd: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Boris Korzun 2021-01-28 13:45:51 UTC
Created attachment 221991 [details]
prometheus2.diff

This patch updates net-mgmt/prometheus2 to v2.24.1.

A full changelog can be found at https://github.com/prometheus/prometheus/releases/tag/v2.24.1

Other changes:
- Removed PROMETHEUS_LOG_DIR from Makefile as absent.
- Added prometheus_syslog_output_* features to rc-script.
- Refactored Makefile and rc-script.

Also fixed #253053.
Comment 1 David O'Rourke 2021-01-28 16:20:25 UTC
Hi,

Thanks for this, sorry I've been a bit slow updating this port recently.

I believe this patch is mostly fine, except I'm confused about the removal of the `load_rc_config` command. Is loading the variables from `/etc/rc.conf` implied somewhere else?

Cheers,
-David
Comment 2 Boris Korzun 2021-01-28 16:28:46 UTC
(In reply to David O'Rourke from comment #1)
It was declared twice (@@ -37 +64 @@). I've removed once.

Thx.
Comment 3 David O'Rourke 2021-01-28 16:32:22 UTC
Aha, so it was. Thanks, I missed that. :)
Comment 4 David O'Rourke 2021-01-28 17:15:51 UTC
Created attachment 221996 [details]
net-mgmt/prometheus2: Update to 2.24.1

This takes the patch from Boris Korzun and fixes a pkg-plist issue revealed by poudriere testport.
Comment 5 David O'Rourke 2021-01-28 17:16:26 UTC
Comment on attachment 221991 [details]
prometheus2.diff

Obsoleted by newer patch with a pkg-plist fix.
Comment 6 pete 2021-01-28 17:46:38 UTC
*** Bug 253053 has been marked as a duplicate of this bug. ***
Comment 7 pete 2021-01-28 17:48:52 UTC
Thanks for rolling the fix to the rc.d script in https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=253053 - i've closed that bug report as requested.
Comment 8 Automation User 2021-01-28 17:50:06 UTC
Build and package info is available at https://gitlab.com/swills/freebsd-ports/pipelines/248285432
Comment 9 commit-hook freebsd_committer 2021-01-28 23:12:39 UTC
A commit references this bug:

Author: dmgk
Date: Thu Jan 28 23:11:58 UTC 2021
New revision: 563164
URL: https://svnweb.freebsd.org/changeset/ports/563164

Log:
  net-mgmt/prometheus2: Update to 2.24.1

  Changes:	https://github.com/prometheus/prometheus/releases/tag/v2.24.1
  PR:		253064
  Submitted by:	Boris Korzun <drtr0jan@yandex.ru>
  Approved by:	David O'Rourke <dor.bsd@xm0.uk> (maintainer)

Changes:
  head/net-mgmt/prometheus2/Makefile
  head/net-mgmt/prometheus2/distinfo
  head/net-mgmt/prometheus2/files/prometheus.in
  head/net-mgmt/prometheus2/pkg-plist
Comment 10 commit-hook freebsd_committer 2021-01-28 23:13:41 UTC
A commit references this bug:

Author: dmgk
Date: Thu Jan 28 23:13:07 UTC 2021
New revision: 563165
URL: https://svnweb.freebsd.org/changeset/ports/563165

Log:
  MFH: r563164

  net-mgmt/prometheus2: Update to 2.24.1

  Changes:	https://github.com/prometheus/prometheus/releases/tag/v2.24.1
  PR:		253064
  Submitted by:	Boris Korzun <drtr0jan@yandex.ru>
  Approved by:	David O'Rourke <dor.bsd@xm0.uk> (maintainer)

Changes:
_U  branches/2021Q1/
  branches/2021Q1/net-mgmt/prometheus2/Makefile
  branches/2021Q1/net-mgmt/prometheus2/distinfo
  branches/2021Q1/net-mgmt/prometheus2/files/prometheus.in
  branches/2021Q1/net-mgmt/prometheus2/pkg-plist
Comment 11 Dmitri Goutnik freebsd_committer 2021-01-28 23:14:17 UTC
Committed, thanks!