Bug 253159 - Display issue on HP Laptop: Can't boot with any FreeBSD
Summary: Display issue on HP Laptop: Can't boot with any FreeBSD
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: Unspecified
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-01 13:05 UTC by nRfEuty7vZzG
Modified: 2021-02-01 15:05 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nRfEuty7vZzG 2021-02-01 13:05:38 UTC
Hi all,

I've tried 3 FreeBSD based distributions on my laptop. Unfortunately, it doesn't even boot on it, causing CPU to hang completely (I can tell be slowly blinking Caps which indicates CPU freeze), requiring physical power off and power on again. I've tried all available safe mode and other options.

Sometimes, it doesn't lock up, but it never goes further than initial boot menu, after that it's only text console with garbled screen where nothing can be read, it's just all messed up, instead of text it's all messed up pixels in inclined bunches where text lines supposed to be.

I think this has something to go with display screen resolution. I have 1366x768 LCD. I remember once wanted to have higher resolution in Linux GRUB and result was the same, garbled inclined lines and nothing readable.

Hardware is HP Probook, AMD A8-4500M APU with 8GB RAM. GPU is called Radeon HD 7640G (I think it's embedded in this CPU). On Linux, everything is working out of the box.

Solution: add some safe mode with fixed resolution of 640x480 or something, or fix underlying problem with display resolution.

Distros tested:
NomadBSD 1.4-RC1 amd64 (based on FreeBSD 12.2)
GhostBSD 21.01.20 amd64 (based on development branch of FreeBSD)
MidnightBSD 2.0.3 amd64 (based on FreeBSD 11)

HW details:
Machine:   Type: Laptop System: Hewlett-Packard product: HP ProBook 4545s v: A1019D1103 serial: <superuser required> 
           Mobo: Hewlett-Packard model: 17EA v: KBC Version 54.20 serial: <superuser required> UEFI: Hewlett-Packard 
           v: 68CPD Ver. F.68 date: 03/28/2018 
Battery:   ID-1: BAT0 charge: 20.8 Wh condition: 21.3/21.3 Wh (100%) 
CPU:       Info: Quad Core model: AMD A8-4500M APU with Radeon HD Graphics bits: 64 type: MCP L2 cache: 2 MiB 
           Speed: 1383 MHz min/max: 1400/1900 MHz Core speeds (MHz): 1: 1383 2: 1387 3: 1384 4: 1382 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Trinity [Radeon HD 7640G] driver: radeon v: kernel 
           Device-2: Primax HP HD Webcam [Fixed] type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.10 driver: loaded: ati,radeon unloaded: modesetting resolution: 1: 1366x768~60Hz 
           2: 1920x1080~60Hz 
           OpenGL: renderer: AMD ARUBA (DRM 2.50.0 / 5.10.7-3-MANJARO LLVM 11.0.1) v: 4.3 Mesa 20.3.3
Comment 1 Rodrigo Osorio freebsd_committer 2021-02-01 14:24:01 UTC
Hi,

You have an issue with the graphic drivers, not the FreeBSD base system itself.

I suggest you to install a standalone (vanilla) FreeBSD [1],
and based on that install Xorg, a GUI and try to find the appropriate
configuration for your video cards[2].

There is some extra information about radeon drivers here:
 => https://wiki.freebsd.org/Graphics

Also, don't hesitate to post a question on the FreeBSD forums[3],
it's probably a better starting point for your problem.

[1] https://docs.freebsd.org/en/books/handbook/bsdinstall/
[2] https://docs.freebsd.org/en/books/handbook/x11/#x-install
[3] https://forums.freebsd.org/
Comment 2 nRfEuty7vZzG 2021-02-01 15:05:45 UTC
Thank you. I wanted to boot any FreeBSD based system first in LiveCD mode before installing in in my laptop, because something else may not be working etc.

Is there anything I can do specifically to get any FreeBSD booted in GUI mode, without installing it?