Bug 253198 - databases/mysql80-server and client patch error
Summary: databases/mysql80-server and client patch error
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Jochen Neumeister
URL:
Keywords:
: 253210 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-02-03 05:31 UTC by Jack
Modified: 2021-02-03 15:45 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (joneum)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jack 2021-02-03 05:31:29 UTC
The latest 8.0.23 has an extra patch that is failing to apply for mysql80-client and mysql80-server

===> Fetching all distfiles required by mysql80-server-8.0.23 for building
===>  Extracting for mysql80-server-8.0.23
=> SHA256 Checksum OK for mysql-boost-8.0.23.tar.gz.
/usr/obj/usr/ports/databases/mysql80-server/work/mysql-8.0.23/sql/sql_hints.yy.cc
/usr/obj/usr/ports/databases/mysql80-server/work/mysql-8.0.23/sql/sql_hints.yy.h
===>  Patching for mysql80-server-8.0.23
===>  Applying FreeBSD patches for mysql80-server-8.0.23 from /usr/ports/databases/mysql80-server/files
===>  Applying FreeBSD patch-CMakeLists.txt
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|--- CMakeLists.txt.orig        2020-09-23 12:37:48 UTC
|+++ CMakeLists.txt
--------------------------
Patching file CMakeLists.txt using Plan A...
Hunk #1 succeeded at 1438 (offset 21 lines).
Hunk #2 succeeded at 1528 (offset 8 lines).
Hunk #3 succeeded at 1585 (offset 21 lines).
Hunk #4 succeeded at 1605 (offset 8 lines).
Hunk #5 succeeded at 1731 (offset 21 lines).
Hunk #6 succeeded at 1753 (offset 8 lines).
done
===>  Applying FreeBSD patch-client_CMakeLists.txt
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|--- client/CMakeLists.txt.orig 2019-09-20 08:30:51 UTC
|+++ client/CMakeLists.txt
--------------------------
Patching file client/CMakeLists.txt using Plan A...
Hunk #1 succeeded at 28 (offset 5 lines).
Hunk #2 succeeded at 37 with fuzz 1 (offset 1 line).
Hunk #3 succeeded at 58 (offset 6 lines).
Hunk #4 succeeded at 70 (offset 2 lines).
Hunk #5 failed at 90.
Hunk #6 succeeded at 253 (offset 140 lines).
Hunk #7 succeeded at 130 (offset 2 lines).
Hunk #8 succeeded at 281 (offset 140 lines).
1 out of 8 hunks failed--saving rejects to client/CMakeLists.txt.rej
done
===>  FAILED Applying FreeBSD patch-client_CMakeLists.txt
===> Cleanly applied FreeBSD patch(es)  patch-CMakeLists.txt
===> FAILED to apply cleanly FreeBSD patch(es)  patch-client_CMakeLists.txt
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/databases/mysql80-server
*** Error code 1

Stop.
make: stopped in /usr/ports/databases/mysql80-server
Comment 1 commit-hook freebsd_committer 2021-02-03 14:13:04 UTC
A commit references this bug:

Author: fluffy
Date: Wed Feb  3 14:12:28 UTC 2021
New revision: 563886
URL: https://svnweb.freebsd.org/changeset/ports/563886

Log:
  databases/mysql80-server: regen patch-client_CMakeLists.txt

  PR:		253198

Changes:
  head/databases/mysql80-server/files/patch-client_CMakeLists.txt
Comment 2 Dima Panov freebsd_committer 2021-02-03 14:15:55 UTC
should be fine now
Comment 3 Jochen Neumeister freebsd_committer 2021-02-03 15:45:51 UTC
*** Bug 253210 has been marked as a duplicate of this bug. ***