Bug 253276 - deskutils/flameshot: GUI does not show up
Summary: deskutils/flameshot: GUI does not show up
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Nicola Vitale
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2021-02-05 18:11 UTC by Mateusz Piotrowski
Modified: 2021-03-10 17:05 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (nivit)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz Piotrowski freebsd_committer 2021-02-05 18:11:13 UTC
When I run "flameshot gui" nothing happens and the command exits with exit code 0. I could find no way to make flameshot do any screenshots. Is the package currently broken? Or could it be my setup?

Details:
- FreeBSD 14.0-CURRENT #6 main-n244600-064e52c2d874
- flameshot-0.8.3
- xorg-server-1.20.9_3,1 
- dmenu-5.0
Comment 1 Tomas Engin 2021-02-11 08:29:59 UTC
I'm having the same problem too.

Details:
- FreeBSD 13.0-BETA-1

- xorg-server-1.20.9_3,1
- flameshot-0.8.3

- qt5-assistant-5.15.2
- qt5-core-5.15.2
- qt5-dbus-5.15.2_1
- qt5-declarative-5.15.2
- qt5-gui-5.15.2_2
- qt5-help-5.15.2_1
- qt5-linguist-5.15.2
- qt5-linguisttools-5.15.2
- qt5-multimedia-5.15.2_1
- qt5-network-5.15.2_1
- qt5-opengl-5.15.2_1
- qt5-printsupport-5.15.2_1
- qt5-sql-5.15.2_1
- qt5-sqldrivers-sqlite3-5.15.2
- qt5-svg-5.15.2_1
- qt5-testlib-5.15.2_1
- qt5-widgets-5.15.2_1
- qt5-x11extras-5.15.2_1
- qt5-xml-5.15.2_1



Also, if I run flameshot -h I get the following output:

QString::arg: Argument missing: ] flameshot

, flameshot
QString::arg: Argument missing: ] flameshot

, [arguments]
Usage: %1 [%2-options] flameshot

Per default runs Flameshot in the background and   adds a tray icon for configuration.

Options:
  -h, --help     Displays this help
  -v, --version  Displays version information

Arguments:
  gui            Start a manual capture in GUI mode.
  screen         Capture a single screen.
  full           Capture the entire desktop.
  launcher       Open the capture launcher.
  config         Configure flameshot.
Comment 2 Tomas Engin 2021-02-11 08:58:02 UTC
I think I found why it wouldn't launch (on my system at least). Dbus wasn't running. I added dbus_enable="YES" and rebooted (I had some updates other too) and it works again.

The error message when running --help still is there but it seem to be fixed upstream:

https://github.com/flameshot-org/flameshot/pull/1289
Comment 3 Mateusz Piotrowski freebsd_committer 2021-02-12 23:09:40 UTC
(In reply to Tomas Engin from comment #2)

I've got D-Bus running and DBUS_SESSION_BUS_ADDRESS is set (I start my window manager with dbus-run-session).
Comment 4 Mateusz Piotrowski freebsd_committer 2021-02-13 13:41:53 UTC
I've spotted the following messages in my console:

dbus-daemon[51019]: [session uid=1001 pid=51019] Activating service name='org.flameshot.Flameshot' requested by ':1.38' (uid=1001 pid=12389 comm="")                                                                                                                                                                                                                                                                                      
dbus-daemon[51019]: [session uid=1001 pid=51019] Activated service 'org.flameshot.Flameshot' failed: Failed to execute program org.flameshot.Flameshot: No such file or directory
Comment 5 Nicola Vitale freebsd_committer 2021-03-09 14:44:18 UTC
IMO, "flameshot gui" doesn't start the program, but only starts "a manual capture in GUI mode", if flameshot is already running. So you must start flameshot before issuing that command (gui).
Comment 6 Mateusz Piotrowski freebsd_committer 2021-03-09 15:54:22 UTC
Right!

The following works:

```
$ flameshot
$ flameshot gui
```

I can see the screenshot menu now. Thanks a lot!
Comment 7 Nicola Vitale freebsd_committer 2021-03-10 09:32:04 UTC
I found the cause: there's a wrong path to the executable flameshot in /usr/local/share/dbus-1/org.freedesktop.Flameshot.service. I'll fix it in the upcoming update of the port. Thanks for the PR.