Bug 253533 - The links to FreeBSD-STABLE and FreeBSD-CURRENT are outdated
Summary: The links to FreeBSD-STABLE and FreeBSD-CURRENT are outdated
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Website (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Daniel Ebdrup Jensen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-15 11:58 UTC by Andreas Bjørnestad
Modified: 2021-02-19 13:28 UTC (History)
2 users (show)

See Also:


Attachments
patch to fix links (1.33 KB, patch)
2021-02-15 11:58 UTC, Andreas Bjørnestad
no flags Details | Diff
patch to fix links (1.32 KB, patch)
2021-02-15 14:19 UTC, Andreas Bjørnestad
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Bjørnestad 2021-02-15 11:58:15 UTC
Created attachment 222463 [details]
patch to fix links

See patch.
Comment 1 Daniel Ebdrup Jensen freebsd_committer 2021-02-15 13:34:36 UTC
Is this related to bug #253391? If so, can I ask you to close this (set it as duplicate of 253391), submit the patch there, and I'll attend to it while my server finishes the head of 14-CURRENT for the raidz3 fix.
Comment 2 Andreas Bjørnestad 2021-02-15 13:46:17 UTC
Will do.

Looks like they're related.

I get confused by https://docs.freebsd.org/en_US.ISO8859-1/books/handbook/ vs. https://docs.freebsd.org/en/books/handbook/.

Which one to use?
Comment 3 Andreas Bjørnestad 2021-02-15 14:19:42 UTC
Created attachment 222470 [details]
patch to fix links
Comment 4 Andreas Bjørnestad 2021-02-15 14:20:47 UTC
I think you might as well apply this patch.

NB! Discard first patch; use the one I uploaded just now.
Comment 5 Daniel Ebdrup Jensen freebsd_committer 2021-02-15 14:37:12 UTC
Please put the updated patch in bug #253391.

Also, bugzilla supports invalidating earlier patches when uploading newer patches, you may want to use that. :)

*** This bug has been marked as a duplicate of bug 253391 ***
Comment 6 Daniel Ebdrup Jensen freebsd_committer 2021-02-15 16:13:24 UTC
Nevermind, I thought the two were related, but they aren't.

I'll fix this as soon as I know whether I need permission to commit.
Comment 7 Andreas Bjørnestad 2021-02-15 20:29:07 UTC
Thanks Daniel.

Sorry, I thought the two were related as well at first. I should've made it clear in #4 that they were not.
Comment 8 Sergio Carlavilla Delgado freebsd_committer 2021-02-16 16:14:23 UTC
Daniel, I'm gonna check this too.
Comment 9 Daniel Ebdrup Jensen freebsd_committer 2021-02-16 16:33:45 UTC
(In reply to Sergio Carlavilla Delgado from comment #8)
Go ahead, Sergio - I may have a bit much on my plate at the moment. :)
Comment 10 commit-hook freebsd_committer 2021-02-19 13:26:40 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/doc/commit/?id=caf336e314133fc1e21754702d9c9ee788ae28cc

commit caf336e314133fc1e21754702d9c9ee788ae28cc
Author:     Andreas Bjørnestad <panden@gmail.com>
AuthorDate: 2021-02-15 14:18:30 +0000
Commit:     Daniel Ebdrup Jensen <debdrup@FreeBSD.org>
CommitDate: 2021-02-19 13:24:23 +0000

    handbook: Fix link to section about tracking a development branch

    PR:             253533

 website/content/en/releases/_index.adoc | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 11 Daniel Ebdrup Jensen freebsd_committer 2021-02-19 13:28:19 UTC
Thank you for your attention to detail. :)