Bug 253553 - sysutils/lsof: no zfs support on 13
Summary: sysutils/lsof: no zfs support on 13
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Larry Rosenman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-16 10:24 UTC by Mathieu Arnold
Modified: 2021-04-16 03:24 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (ler)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu Arnold freebsd_committer 2021-02-16 10:24:43 UTC
I upgraded our package builder machine to 13.0-BETA2 to prepare our first 13.0 deployments, and when I tried to look at something, I got this:

# lsof -p 43535
lsof: WARNING: no ZFS support has been defined.
      See 00FAQ for more information.
COMMAND   PID USER   FD   TYPE DEVICE  SIZE/OFF NODE NAME
find    43535 root    0u  VCHR  0,181 0t3109790  181 /dev/pts/2
find    43535 root    1u  VCHR  0,181 0t3109790  181 /dev/pts/2
find    43535 root    2u  VCHR  0,181 0t3109790  181 /dev/pts/2
find    43535 root    3r                             unknown file system type: zfs
find    43535 root    4r                             unknown file system type: zfs
find    43535 root    5r                             unknown file system type: zfs

I had a look at 00FAQ, but it is way beyond me.
Comment 1 Raivo Hool 2021-03-03 22:36:23 UTC
Lsof looks for zfs_znode.h to determine whether to build ZFS support. Said file has moved from the contrib/opensolaris directory to contrib/openzfs etc., and since #include paths are hard coded in Configure, it doesn't get picked up, and the support isn't included. I tried playing around with it a bit today, but encountered include escalation and put it on hold. Include paths are set in the Makefile, but there are too many files in different subdirectories with identical names that get referenced that it was not immediately apparent which need to be included and which do not.