Bug 253575 - net/samba412: Undefined symbol "memalign@FBSD_1.6"
Summary: net/samba412: Undefined symbol "memalign@FBSD_1.6"
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Timur I. Bakeyev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-17 02:40 UTC by Jonas
Modified: 2021-02-18 01:54 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (timur)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas 2021-02-17 02:40:42 UTC
Hi,

I'm running FreeBSD 12.2-RELEASE-p3 7851f4a452d(HEAD) and installed samba412 via "pkg install" in a jail based on 12.1-RELEASE-p13.

Once I run smbclient I get the following error: ld-elf.so.1: /usr/local/lib/samba4/libsamba-util.so.0: Undefined symbol "memalign@FBSD_1.6"

readelf -a /usr/local/lib/samba4/libsamba-util.so.0 | grep memalign
000000074628 00a700000007 R_X86_64_JUMP_SLOT  0000000000000000 memalign + 0
   167: 0000000000000000     0 FUNC    GLOBAL DEFAULT  UND memalign@FBSD_1.6 (15)
   360: 000000000006d530    46 FUNC    GLOBAL DEFAULT   13 memalign_array@@SAMBA_UTIL_0.0.1 (2)

Does anyone know what could cause this and how it can be fixed?
I also tried samba411 and samba413, both produce the same result.
I had this running without any issues on a FreeBSD 12.1 host before.
Comment 1 VVD 2021-02-17 11:08:25 UTC
12.1 is not supported, all packaged build for 12.2 now and are not compatible with 12.1.
Comment 2 Jonas 2021-02-18 01:54:16 UTC
Thanks for the response! I'm new to FreeBSD and wasn't aware of that.